• hdoj1004--Let the Balloon Rise


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink
     
    使用C++ STL中的map模板
    #include<iostream>
    #include<cstdio>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    
    void solve()
    {
        int T, max, t;
        map<string, int> color_count;
        string color;
        while(cin>>T && T) {
            max = 0;
            while(T--) {
                cin>>color;
                ++color_count[color];
            }
            map<string, int>::const_iterator ii, it;
            it = color_count.begin();
            while(it != color_count.end()) {
                if(max < it->second) {
                    max = it->second;
                    ii = it;
                }
                it++;
            }
            cout<<ii->first<<endl;
            color_count.clear();
        }
    }
    
    int main()
    {     
        solve();
        return 0;
    }
  • 相关阅读:
    url 路径的拼接
    java 实现导出Excel文件
    window 使用频率最高的快捷键
    jeesite 框架的简单应用
    一个软件开发者的解决问题的心得——善于利用蛛丝马迹
    在linux上安装dotnetcore
    c#多线程同步之EventWaitHandle使用
    sharepoint 2013 安装
    模板模式的应用
    正则表达式的应用
  • 原文地址:https://www.cnblogs.com/xueda120/p/3573977.html
Copyright © 2020-2023  润新知