• sicily 1052. Candy Sharing Game


    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB 

    Description

    A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

    Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

    Input

    The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

    Output

    For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

    Sample Input

    6
    36
    2
    2
    2
    2
    2
    11
    22
    20
    18
    16
    14
    12
    10
    8
    6
    4
    2
    4
    2
    4
    6
    8
    0

    Sample Output

    15 14
    17 22
    4 8
    
    
    Notes:
    The game ends in a finite number of steps because:
    1. The maximum candy count can never increase.
    2. The minimum candy count can never decrease.
    3. No one with more than the minimum amount will ever decrease to the minimum.
    4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase
    #include <iostream>
    #include <vector>
    
    using namespace std;
    
    int main(int argc, char const *argv[])
    {
        int stuNum;
        vector<int> stuCandy;
        while (cin >> stuNum && stuNum != 0) {
            stuCandy.resize(stuNum);
            for (int i = 0; i != stuNum; ++i)
                cin >> stuCandy[i];
            int roundNum = 0;
            while (++roundNum) {
                int firstCandy = stuCandy[0];
                int i;
                for (i = 0; i != stuNum - 1; ++i) {
                    stuCandy[i] -= (stuCandy[i] / 2);
                    stuCandy[i] += (stuCandy[i + 1] / 2);
                    if (stuCandy[i] % 2 != 0)
                        stuCandy[i] += 1;            
                }
                stuCandy[i] -= (stuCandy[i] / 2);
                stuCandy[i] += (firstCandy / 2);
                if (stuCandy[i] % 2 != 0)
                    stuCandy[i] += 1;    
    
                for (i = 0; i != stuNum - 1; ++i) {
                    if (stuCandy[i] != stuCandy[i + 1])
                        break;
                }
                if (i == stuNum - 1)
                    break;
            }
            cout << roundNum << " " << stuCandy[0] << endl;
        }
        return 0;
    }
  • 相关阅读:
    [Android-NDK编译] ndk 编译 c++ 兼容性问题汇总整理
    [云计算] 001.云计算简介
    eatwhatApp开发实战(十一)
    eatwhatApp开发实战(十)
    [Unity2d系列教程] 002.引用外部DLL
    Istio Sidecar
    Kubernetes Dashborad 搭建
    Istio 1.6架构及性能
    kubeadm 搭建kubernetes集群环境
    docker 安装
  • 原文地址:https://www.cnblogs.com/xiezhw3/p/4025265.html
Copyright © 2020-2023  润新知