• 【洛谷 2871】手链


    题目描述

    Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

    输入输出格式

    输入格式:

    * Line 1: Two space-separated integers: N and M

    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

    第一行:物品个数N和背包大小M

    第二行至第N+1行:第i个物品的重量C[i]和价值W[i]

    输出格式:

    * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    输出一行最大价值。

    输入输出样例

    输入样例#1: 复制
    4 6
    1 4
    2 6
    3 12
    2 7
    输出样例#1: 复制
    23

    题解:背包qwq不须解释
    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    typedef long long ll;
    using namespace std;
    #define maxn 3403
    #define maxm 12881
    int m,n,w[maxn],c[maxn],f[maxm];
    int main()
    {    
        scanf("%d%d",&n,&m);    
        for (int i=1;i<=n;++i)        
            scanf("%d%d",&w[i],&c[i]);    
        for (int i=1;i<=n;++i)        
            for (int v=m;v>=w[i];--v)            
                if (f[v-w[i]] + c[i] > f[v])               
                    f[v] = f[v-w[i]]+c[i];    
        printf("%d",f[m]);    
        return 0;
    }
  • 相关阅读:
    bash 复制文件
    taro 异步请求与列表渲染
    get请求带body的formdata非json实现AsyncHttpClient解决
    vue These dependencies were not found: * corejs/modules/es.array.iterator in ./node_modules/@babe
    Java HttpClient中文乱码解决
    SpringBoot参数校验及异常捕获
    MAC在Chrome安装vue插件
    HttpClient工具类(包含请求头header设置token)
    SpringBoot解决跨域
    2021 BDCI 华为零售商品识别竞赛一等奖方案分享
  • 原文地址:https://www.cnblogs.com/wuhu-JJJ/p/11182336.html
Copyright © 2020-2023  润新知