• 洛谷P2882 [USACO07MAR]面对正确的方式Face The Right Way(贪心)


    题目描述
    Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

    Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

    Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

    N头牛排成一列1<=N<=5000。每头牛或者向前或者向后。为了让所有牛都 面向前方,农夫每次可以将K头连续的牛转向1<=K<=N,求操作的对应的最小K和最少次数M。

    输入输出格式
    输入格式:
    Line 1: A single integer: N

    Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

    输出格式:
    Line 1: Two space-separated integers: K and M

    输入输出样例
    输入样例#1:
    7
    B
    B
    F
    B
    F
    B
    B
    输出样例#1:
    3 3
    说明
    For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

    这道题可以枚举每一种情况,然后O(n)判断是否可行。用all来表示当前的所有操作对这个点所产生的影响,并时刻更新。别忘了最后判断是否已经全部为F。

    #include <bits/stdc++.h>
    #define int long long
    #define For(i, a, b) for (register int i = a; i <= b; i++)
    using namespace std;
    int n, a[5500], ans, rev[5500], all, tot, mn = 0x3f3f3f3f, mnat;
    char ch;
    bool ok(int x) {
        memset(rev, 0, sizeof rev);
        all = 0, tot = 0;
        For(i, 1, n - x + 1) {
            if ((a[i] + all) % 2 == 1) {
                rev[i] = 1;
                tot++;
            }
            all += rev[i];
            if (i - x + 1 >= 1)
                all -= rev[i - x + 1];
        }
        if (tot > mn)
            return 0;
        For(i, n - x + 2, n) {
            if ((a[i] + all) % 2 == 1)
                return 0;
            if (i - x + 1 >= 1)
                all -= rev[i - x + 1];
        }
        return 1;
    }
    signed main() {
        cin >> n;
        For(i, 1, n) {
            cin >> ch;
            a[i] = (ch == 'F' ? 0 : 1);
        }
        For(i, 1, n) {
            if (ok(i) && tot < mn) {
                mn = tot;
                mnat = i;
            }
        }
        cout << mnat << " " << mn << '
    ';
        return 0;
    }
    
  • 相关阅读:
    微信小程序登录(包括获取不到unionid的情况)
    ionic生成签名的APK方法总结
    iframe的简单使用方法
    常见的浏览器端的存储技术:cookie
    AJAX 过程总结
    react相关知识总结2
    正则表达式相关知识点
    vue相关知识汇总
    react相关知识汇总
    Vue-Router核心实现原理
  • 原文地址:https://www.cnblogs.com/wky32768/p/11185487.html
Copyright © 2020-2023  润新知