• POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover【数学计算】


    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 125708   Accepted: 61333

    Description

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00
    

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)

    Source



    Regionals 2001 >> North America - Mid-Central USA


    问题链接POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover

    题意简述已知c=1/2+1/3+1/4+....1/(n+1),输入m(m是浮点数),求正整数n使得c>=m。

    问题分析:从小到大试探n即可。

    程序说明:(略)


    AC的C语言程序如下:

    /* POJ1003 UVALive2294 HDU1056 ZOJ1045 Hangover */
    
    #include <iostream>
    #include <cstdio>
    
    using namespace std;
    
    const double one = 1.0;
    
    int main()
    {
        double len, sum, d;
        int i;
    
        while((cin >> len) && len != 0.00) {
            i = 1;
    
            d = 2.0;
            sum = one / d;
            while(sum < len) {
                d += 1.0;
                sum += (one / d);
                i++;
            }
    
            cout << i << " card(s)" << endl;
        }
    
        return 0;
    }


  • 相关阅读:
    Vmware中“重新安装vmware-tools”按钮置灰如何解决
    如何实现Sublime Text3快速生成html代码
    Windows窗体编程你也行
    .NET基础技术总结
    C#考试题第一波
    C#认证题4(使用标准Windons窗体控件)
    通讯录数据库
    C#认证试题(3)
    c#认证题(2)
    c#认证试题
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7564392.html
Copyright © 2020-2023  润新知