描述
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).
Some cows like each other and want
to be within a certain distance of each other in line. Some really
dislike each other and want to be separated by at least a certain
distance. A list of ML (1 <= ML <= 10,000) constraints describes
which cows like each other and the maximum distance by which they may be
separated; a subsequent list of MD constraints (1 <= MD <=
10,000) tells which cows dislike each other and the minimum distance by
which they must be separated.
Your job is to compute, if
possible, the maximum possible distance between cow 1 and cow N that
satisfies the distance constraints.
输入
Line 1: Three space-separated integers: N, ML, and MD.
Lines
2..ML+1: Each line contains three space-separated positive integers: A,
B, and D, with 1 <= A < B <= N. Cows A and B must be at most D
(1 <= D <= 1,000,000) apart.
Lines ML+2..ML+MD+1: Each
line contains three space-separated positive integers: A, B, and D, with
1 <= A < B <= N. Cows A and B must be at least D (1 <= D
<= 1,000,000) apart.
输出
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
样例输入
4 2 1
1 3 10
2 4 20
2 3 3
样例输出
27
提示
There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.
The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
const int N=1005,M=20005;
int head[N],cnt=1;
struct edge
{
int v,w,next;
}edges[M];
void add(int u,int v,int w)
{
edges[cnt].v=v;
edges[cnt].w=w;
edges[cnt].next=head[u];
head[u]=cnt++;
}
上面这个意思是每次在链表结构里的首部存一条(u,v)权值为w的边,这个存储和输入方式是成逆序的,而且时间O(1),空间没有浪费
所以只需要i=head[u];i!=0;i=edges[i].next就可以访问所有从U出发的边
然后这道题就是建图,建完图跑最短路径,这里用SPFA可以判断负圈
1 #include<cstdio> 2 #include<cstring> 3 #include<stack> 4 using namespace std; 5 #define INF 0x3f3f3f3f 6 const int N=1005,M=20005; 7 struct edge 8 { 9 int v,w,next; 10 }edges[M]; 11 int Dist[N],Vis[N],head[N],In[N],cnt=1; 12 void add(int u,int v,int w) 13 { 14 edges[cnt].v=v; 15 edges[cnt].w=w; 16 edges[cnt].next=head[u]; 17 head[u]=cnt++; 18 } 19 int spfa(int n) 20 { 21 memset(Dist,INF,sizeof(Dist)); 22 stack<int> st; 23 st.push(1); 24 Dist[1]=0; 25 while(!st.empty()) 26 { 27 int u=st.top();st.pop(); 28 Vis[u]=0; 29 for(int i=head[u];i;i=edges[i].next) 30 { 31 int v=edges[i].v,w=edges[i].w; 32 if(Dist[v]>Dist[u]+w) 33 { 34 Dist[v]=Dist[u]+w; 35 if(Vis[v])continue; 36 Vis[v]=1; 37 st.push(v); 38 if(++In[v]>n)return 0;//一个点的入栈次数>n说明存在负圈,无解 39 } 40 } 41 } 42 return 1; 43 } 44 int main() 45 { 46 int n,ml,md,a,b,c; 47 scanf("%d%d%d",&n,&ml,&md); 48 for(int i=0;i<ml;i++) 49 { 50 scanf("%d%d%d",&a,&b,&c); 51 add(a,b,c); 52 } 53 for(int i=0;i<md;i++) 54 { 55 scanf("%d%d%d",&a,&b,&c); 56 add(b,a,-c);//差分约束 57 } 58 if(spfa(n)==0)printf("-1 "); 59 else printf("%d ",Dist[n]==INF?-2:Dist[n]); 60 return 0; 61 }