• poj 3069 Saruman's Army


    Saruman's Army
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8477   Accepted: 4317

    Description

    Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

    Input

    The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

    Output

    For each test case, print a single integer indicating the minimum number of palantirs needed.

    Sample Input

    0 3
    10 20 20
    10 7
    70 30 1 7 15 20 50
    -1 -1

    Sample Output

    2
    4

    Hint

    In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

    In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

    简单的贪心。

    #include<iostream>
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int a[1005];
    int main()
    {
        int r,n;
        while(~scanf("%d%d",&r,&n)&&r>=0&&n>-0)
        {
            for(int i=0;i<n;i++)
            {
                scanf("%d",a+i);
            }
            sort(a,a+n);
            int i=0,s=0;
            int ans=0;
            while(i<n)
            {
                s=a[i++];
                while(s+r>=a[i]&&i<n) i++;
                if(i>n) break;
                int p=a[i-1];
                ans++;
                while(p+r>=a[i]&&i<n) i++;
    
    
            }
            cout<<ans<<endl;
        }
    }
    View Code
  • 相关阅读:
    第七周java学习总结
    第六周java学习总结
    20175206迭代与JDB测试
    第五周java学习总结
    实验一 Java开发环境的熟悉(Linux + Eclipse)
    第四周java学习总结
    第三周java学习总结
    es6零基础学习之项目目录创建(一)
    软键盘影响页面布局之定位
    当input的框全部不为空时,提交按钮变色
  • 原文地址:https://www.cnblogs.com/superxuezhazha/p/6130020.html
Copyright © 2020-2023  润新知