• [ACM


    Problem Description

    There is a hill with n holes around. The holes are signed from 0 to n-1.



    A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

    Input

    The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

    Output

    For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

    Sample Input

    2
    1 2
    2 2
    

    Sample Output

    NO
    YES
    

    Author

    weigang Lee

    Source

    杭州电子科技大学第三届程序设计大赛

    解题思路:

    本题的本质问题是判断两个数m,n是否互质(除了1,没有其它公约数),如果互质,safe hole不存在(即所有的洞狼都能找一遍),如果不互质,safe  hole 则存在。m=3 n=8 和 m=2  n=8为首先按照以下编号

    0      1      2        3     4      5      6      7

     8      9     10      11   12   13   14   15 

    n=7  m=2         n=7   m=3

    0   1   2   3    4    5   6

    7   8   9   10 11 12 13

    当编号对n取余既有奇数又有偶数时,狼可以把所有的洞访问一遍,当编号n对n取余都是奇数或都是偶数时,狼有些洞访问不到。

    代码:

    #include <iostream>
    using namespace std;
    
    int gcd(int m,int n)
    {
        return n==0?m:gcd(n,m%n);
    }//最大公约数
    int main()
    {
        int t,ti;
        cin>>t;
        int m,n;
        for(ti=1;ti<=t;ti++)
        {
            cin>>m>>n;
            if(gcd(m,n)==1)//互质
                cout<<"NO"<<endl;
            else
                cout<<"YES"<<endl;
        }
        return 0;
    }
    


    运行截图:

  • 相关阅读:
    一款纯css3实现的鼠标经过按钮特效
    一款基于jquery漂亮的按钮
    一款仿ios7的switches开关按钮
    基于jquery的可拖动div
    一款基于jquery ui漂亮的可拖动div实例
    一款html5和css3实现的小机器人走路动画
    一款纯css3实现的图片3D翻转幻灯片
    纯css3实现图片三角形排列
    7款基于jquery的动画搜索框
    一款纯css3实现的机器人看书动画效果
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697820.html
Copyright © 2020-2023  润新知