• [结题报告]10340 All in All Time limit: 3.000 seconds


    Problem E

    All in All

    Input: standard input

    Output: standard output

    Time Limit: 2 seconds

    Memory Limit: 32 MB

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

    Input Specification

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

    Output Specification

    For each test case output, if s is a subsequence of t.

    Sample Input

    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter

    Sample Output

    Yes
    No
    Yes
    No

    参考代码:
    这道题给定2个字符串,求前字符串是否在后字符串出现(不要求连续),利用循环可以求出,但是这道题必须注意到的是,2个数组的定义时,务必要足够大,经证明,200000够大,定义过小,会出现Runtime error.
    #include"stdio.h"
    #include"string.h"
    int main()
    {
     char s1[200000],s2[200000];
     int i,j;
     while (scanf("%s%s",&s1,&s2)!=EOF)
     {
      for (i=0,j=0;s1[i]!='\0'&&s2[j]!='\0';j++)
      if (s1[i]==s2[j]) ++i;
      if (s1[i]=='\0') printf("Yes\n");
                  else printf("No\n");
     }
     return 0;
    }
     
  • 相关阅读:
    如何提高英阅读英文技术资料
    如何阅读英语文章
    vijosP1223麦森数
    vijosP1359 Superprime
    vijosP1319 数列
    vijosP1447 开关灯泡
    vijosP1164 曹冲养猪
    vijosP1016 北京2008的挂钟
    洛谷P1457 城堡(The Castle)
    洛谷P1294 高手去散步
  • 原文地址:https://www.cnblogs.com/sjy123/p/2919215.html
Copyright © 2020-2023  润新知