• Codeforces--617B--Chocolate(规律)


    

    Chocolate

    Time Limit: 1000MS

      Memory Limit: 262144KB   64bit IO Format: %I64d & %I64u

    Status

    Description

    Bob loves everything sweet. His favorite chocolate bar consists of pieces, each piece may contain a nut. Bob wants to break the bar of chocolate into multiple pieces so that each part would contain exactly one nut and any break line goes between two adjacent pieces.

    You are asked to calculate the number of ways he can do it. Two ways to break chocolate are considered distinct if one of them contains a break between some two adjacent pieces and the other one doesn't.

    Please note, that if Bob doesn't make any breaks, all the bar will form one piece and it still has to have exactly one nut.

    Input

    The first line of the input contains integer n (1 ≤ n ≤ 100) — the number of pieces in the chocolate bar.

    The second line contains n integers ai (0 ≤ ai ≤ 1), where 0 represents a piece without the nut and 1 stands for a piece with the nut.

    Output

    Print the number of ways to break the chocolate into multiple parts so that each part would contain exactly one nut.

    Sample Input

    Input
    3
    0 1 0
    
    Output
    1
    
    Input
    5
    1 0 1 0 1
    
    Output
    4
    

    Sample Output

    Hint

    In the first sample there is exactly one nut, so the number of ways equals 1 — Bob shouldn't make any breaks.

    In the second sample you can break the bar in four ways:

    10|10|1

    1|010|1

    10|1|01

    1|01|01

    Source


    两个1之间有几种选择,然后连乘,跟组合数思想是一样的


    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int a[110],b[110];
    int main()
    {
    	int n;
    	while(cin>>n)
    	{
    		memset(a,0,sizeof(a));
    		memset(b,0,sizeof(b));
    		__int64 ans=1;
    		int k=0;
    		for(int i=1;i<=n;i++)
    		{
    			cin>>a[i];
    			if(a[i])
    			b[k++]=i;
    		}
    		if(k==0)
    		cout<<0<<endl;
    		else if(k==1)
    		cout<<1<<endl;
    		else
    		{
    			for(int i=1;i<k;i++)
    			ans=ans*(b[i]-b[i-1]);
    			cout<<ans<<endl;
    		}
    	}
    	return 0;
    }

  • 相关阅读:
    LeetCode
    LeetCode
    LeetCode
    LeetCode
    codevs 2977 二叉堆练习1x
    codevs 2010 求后序遍历x
    二叉树的序遍历x(内含结构体与非结构体版x)
    医院设置x
    求后序遍历x
    [LightOJ1017]Brush (III)(dp)
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273425.html
Copyright © 2020-2023  润新知