• poj3104Drying_最大化最小值


    Drying
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 21032   Accepted: 5290

    Description

    It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

    Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

    There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

    Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

    The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

    Input

    The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

    Output

    Output a single integer — the minimal possible number of minutes required to dry all clothes.

    Sample Input

    sample input #1
    3
    2 3 9
    5
    
    sample input #2
    3
    2 3 6
    5

    Sample Output

    sample output #1
    3
    
    sample output #2
    2

    Source

    Northeastern Europe 2005, Northern Subregion
    思路:二分minute。设每个clothes所需y次烘干,那么就有minute-y次自然干。minute-y+y*k>=x[i]。解y>=(x[i]-minute)/(k-1)。注意k等于1的情况
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    using namespace std;
    const int MAXN=100005;
    int N,M;
    int a[MAXN];
    bool f(int t)         //最小值为mid的时的个数
    {
        int sum=0;
    
        for(int i=0;i<N;i++)
        {
            if(a[i]<=t)continue;
            sum+=(int)ceil((a[i]-t)*1.0/(M-1));//取整
            if(sum>t)return false;
        }
       return true;
    }
    
    int main()
    {
        while(scanf("%d",&N)!=EOF)
        {
           int high=0,low=0,mx=0;
            for(int i=0;i<N;i++)
            {
                scanf("%d",&a[i]);
                mx=max(mx,a[i]);
            }
         scanf("%d",&M);
          if(M==1){
            cout<<mx<<endl;
            //return 0;
          }
            else{  low=0;
                   high=0x3f3f3f3f;
            while(high-low>1)
            {
                int  mid=(low+high)/2;
                if(!f(mid))
                {
                    low=mid;
                }
                else
                {
                    high=mid;
                }
    
            }
            cout<<high<<endl;
            }
        }
        return 0;
    }
    

      

  • 相关阅读:
    Swift 高级运算符
    drawer navigation, tabhostFragment 默认导向
    Jquery easyUI datagrid载入复杂JSON数据方法
    逆向project第005篇:跨越CM4验证机制的鸿沟(下)
    据说有99%的人都会做错的面试题
    POJ3187 Backward Digit Sums 【暴搜】
    Android
    arm-linux-gcc 的使用
    GNU 交叉工具链的介绍与使用
    使用当前平台的 gcc 编译内核头文件
  • 原文地址:https://www.cnblogs.com/passion-sky/p/9006452.html
Copyright © 2020-2023  润新知