• POJ3187 Backward Digit Sums 【暴搜】


    Backward Digit Sums
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4487   Accepted: 2575

    Description

    FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

        3   1   2   4
    
          4   3   6
    
            7   9
    
             16
    Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

    Write a program to help FJ play the game and keep up with the cows.

    Input

    Line 1: Two space-separated integers: N and the final sum.

    Output

    Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

    Sample Input

    4 16

    Sample Output

    3 1 2 4

    Hint

    Explanation of the sample: 

    There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

    Source

    先把第一行每一个位置要加的次数求出来。会发现是一个杨辉三角,将这个杨辉三角打成表。每次枚举第一行的组成情况,直接用这个表计算结果。

    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    
    int lev[12][12];
    int box[12], N, S;
    
    int main() {
        int i, j, sum;
        lev[1][1] = 1;
        for(i = 2; i <= 10; ++i)
            for(j = 1; j <= i; ++j)
                if(j == 1 || j == i) lev[i][j] = 1;
                else lev[i][j] = lev[i-1][j] + lev[i-1][j-1];
                
        while(scanf("%d%d", &N, &S) == 2) {
            for(i = 1; i <= N; ++i)
                box[i] = i;
            do {
                sum = 0;
                for(i = 1; i <= N; ++i)
                    sum += box[i] * lev[N][i];
                if(sum == S) break;
            } while(std::next_permutation(box + 1, box + N + 1));
    
            for(i = 1; i <= N; ++i)
                printf("%d%c", box[i], i == N ?

    ' ' : ' '); } return 0; }



  • 相关阅读:
    解决“不是有效的win32应用程序”问题
    mysql 5.7 windows install
    Redis
    给 string 添加一个 GetInputStream 扩展方法
    定时任务为什么不用Timer
    怎样改动 VC6.0 4.0 2010 打印预览界面上的文字
    大数据时代的万象变化
    &lt;监听器模式&gt;在C++ 与 Java 之间实现的差异
    工厂模式之抽象工厂模式
    UIButton上字体的对齐方式
  • 原文地址:https://www.cnblogs.com/llguanli/p/6757107.html
Copyright © 2020-2023  润新知