• H


    H - Gold Coins(2.4.1)
    Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

    Description

    The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer. 

    Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1). 

    Input

    The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

    Output

    There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

    Sample Input

    10
    6
    7
    11
    15
    16
    100
    10000
    1000
    21
    22
    0
    

    Sample Output

    10 30
    6 14
    7 18
    11 35
    15 55
    16 61
    100 945
    10000 942820
    1000 29820
    21 91
    22 98
    #include<iostream>
    #include<cmath>
    using namespace std;
    int main( ) 
    { 
    	int n;
    	int a,b,s,k;
       while(cin>>n&&n)
       {
    	   s=0;
    	  k=(-1+sqrt(1+8*n))/2;
    	  for(a=1;a<=k;a++)
    		  s=s+a*a;
    	  s=s+(n-k*(k+1)/2)*a;
    	  cout<<n<<' '<<s<<endl;
       }
        return 0; 
    } 


  • 相关阅读:
    Photoshop教程,视频MP4格式转换为GIF格式
    pyqgis环境配置
    R 输出函数 格式化输出 打印函数
    linux ubuntu 更改终端的默认设置,终端大小,字体
    wps 显示所有的字符,将参考文献排序,插入目录
    在 word 中 怎么让表格旋转方向
    linux argc argv
    linux 命令行的快捷键 vim
    linux 操作系统,以及一般的操作系统 所看书籍
    win 10 快速启动 某些程序
  • 原文地址:https://www.cnblogs.com/mqxnongmin/p/10949396.html
Copyright © 2020-2023  润新知