• 1065 A+B and C (64bit) (20 分)(模拟)


    Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

    Input Specification:

    The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

    Output Specification:

    For each test case, output in one line “Case #X: true” if A+B>C, or “Case #X: false” otherwise, where X is the case number (starting from 1).”

    Sample Input:

    3
    1 2 3
    2 3 4
    9223372036854775807 -9223372036854775808 0

    Sample Output:

    Case #1: false
    Case #2: true
    Case #3: false

    分析:

    因为A、B的大小为[-2^63, 2^63],用long long 存储A和B的值,以及他们相加的值sum:

    如果A > 0, B < 0 或者 A < 0, B > 0,sum是不可能溢出的

    如果A > 0, B > 0,sum可能会溢出,sum范围理应为(0, 2^64 – 2],溢出得到的结果应该是[-2^63, -2]是个负数,所以sum < 0时候说明溢出了

    如果A < 0, B < 0,sum可能会溢出,同理,sum溢出后结果是大于0的,所以sum > 0 说明溢出了

    原文链接:https://blog.csdn.net/liuchuo/article/details/52109211

    题解

    注意用用cin读取数据最后一个样例报错~

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n;
        cin>>n;
        for(int i=1;i<=n;i++){
            long long int a,b,c;
            scanf("%lld %lld %lld", &a, &b, &c);
            long long int sum=a+b;
            if(a>0&&b>0&&sum<0){
                printf("Case #%d: true\n",i);
            }else if(a<0&&b<0&&sum>=0)
                printf("Case #%d: false\n",i);
            else if(sum>c)
                printf("Case #%d: true\n",i);
            else
                printf("Case #%d: false\n",i);
        }
    
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15613677.html

  • 相关阅读:
    外键的三种形式
    MySQl创建用户和授权
    Django模板系统
    Django 简介
    jQuery
    JavaScript的BOM和DOM
    JS中的关键字和保留字
    Git 源码管理工具简单入门
    Git使用
    常见的三种SQL分页方式
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15613677.html
Copyright © 2020-2023  润新知