• poj 2377 Bad Cowtractors


    Bad Cowtractors
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10194   Accepted: 4333

    Description

    Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

    Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

    Input

    * Line 1: Two space-separated integers: N and M 

    * Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

    Output

    * Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

    Sample Input

    5 8
    1 2 3
    1 3 7
    2 3 10
    2 4 4
    2 5 8
    3 4 6
    3 5 2
    4 5 17

    Sample Output

    42


    题意:给定每条路线间须要的费用,建造一个最贵的网络线路(随意两节点都能够互相达到,可是不存在回路),求最多须要花费多少钱。

    思路:最生成树。

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    #define M 1500000
    int f[M];
    int sum,t;
    struct node
    {
    	int x,y,l;
    }p[M],v[M];
    
    bool cmp(node a,node b)
    {
    	return (a.l>b.l);
    }
    
    void Init (int n)
    {
    	for(int i=1;i<=n;i++)
    		f[i]=i;
    }
    
    int find(int x)
    {
    	if(x!=f[x])
    		return f[x]=find(f[x]);
    	return f[x];
    }
    
    int Union(int x,int y,int z)
    {
    	int fx,fy;
    	fx=find(x);
    	fy=find(y);
    	if(fx!=fy)
    	{
    		f[fy]=fx;
    		sum+=z;
    		t++;
    	}
        return sum;
    }
    
    int main ()
    {
    	int n,m;
    	int i;
    	while(cin>>n>>m)
    	{
    		Init(n);
    		memset(p,0,sizeof(p));
    		sum=0;
    		t=0;
    		for(i=0;i<m;i++)
    			cin>>p[i].x>>p[i].y>>p[i].l;
    		
    		sort(p,p+m,cmp);
    
    		for(i=0;i<m;i++)
    		  Union(p[i].x,p[i].y,p[i].l);
    	
    		if(t==n-1)
    			cout<<sum<<endl;
    		else 
    			cout<<"-1"<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    随感
    Serializable方式实现数据传递
    Serializable方式实现数据传递
    MeterailDesign最佳UI设计
    MeterailDesign最佳UI设计
    Metarial Design之ToolBar
    Metarial Design之ToolBar
    Android"寻龙点穴"指南针
    如何完全卸载VS2010(亲自体验过)
    【杭电】[2049]不容易系列之(4)——考新郎
  • 原文地址:https://www.cnblogs.com/mfrbuaa/p/3893118.html
Copyright © 2020-2023  润新知