数字
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
定义f(x) = {比x小,不可以被x整除并且不和x互质的数的个数}(x为正整数)。
当f(x) 是奇数的时候我们称x为“奇真数”。
给出两个数x,y求区间[x,y]内的“奇真数”的个数。
Input
第一行输入一个数N代表测试数据个数(N<=20)。接下来N行每行两个正整数x , y ( 0 < x <= y < 2^31)。
Output
对于每个测试数据输出“奇真数”的个数,每行输出一个结果。
Sample Input
2
1 1
1 10
Sample Output
0
4
Hint
中国海洋大学第三届“朗讯杯”编程比赛高级组试题
详细题解:泳裤王子的博客-HDU 4279 Number [数论+简证]
import java.util.*;
public class Main
{
public static void main(String[] args)
{
Scanner cin = new Scanner(System.in);
long a,b,t;
t = cin.nextLong();
while(t-->0)
{
a = cin.nextLong();
b = cin.nextLong();
System.out.println(f(b) - f(a - 1));
}
cin.close();
}
static long f(long a)
{
if(a<=2)
return 0;
if((long)Math.sqrt(a)%2==1)
return a / 2 - 1;
else
return a / 2 - 2;
}
}