• FZU-2271 X(Floyd)


     Problem 2271 X

    Accept: 303    Submit: 1209
    Time Limit: 1500 mSec    Memory Limit : 32768 KB

     Problem Description

    X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

    Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

     Input

    The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

    Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

     Output

    For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

    See the sample input and output for more details.

     Sample Input

    2 2 3 1 2 1 1 2 1 1 2 2 3 3 1 2 1 2 3 1 1 3 1

     Sample Output

    Case 1: 2 Case 2: 0

     Source

    第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)
    题意:一共m条路,去掉最多的路,使原本任意两点最短路不变,最多可以去掉几条路。因为是任意两点,所以可以用Floyd。
    代码:
    #include <iostream>
    #include<cstdio>
    #include<cmath>
    #include<algorithm>
    #include<queue>
    #include<stack>
    #include<string>
    #include<cstring>
    using namespace std;
    #define INF 0x3f3f3f3f
    int mapp[150][150];
    int flag[150][150];
    int dis[150][150];
    int diss[150][150];
    int sum;
    int n,m;
    void Floyd(){
            for(int k=1;k<=n;k++){
                    for(int i=1;i<=n;i++){
                            if(mapp[i][k]==INF)continue;
                            for(int j=1;j<=n;j++){
                                    if(mapp[i][j]>=mapp[i][k]+mapp[k][j]&&i!=j){
                                            if(dis[i][j]==0&&flag[i][j]==1)
                                            {
                                                    sum++;dis[i][j]=dis[j][i]=1;
                                                    diss[i][k]=diss[k][i]=diss[k][j]=diss[j][k]=1;
                                            }
                                            mapp[i][j]=mapp[i][k]+mapp[k][j];
                                            mapp[j][i]=mapp[i][j];
    
    
                                    }
                            }
                    }
            }
    }
    
    int main()
    {
        std::ios::sync_with_stdio(false);
        int t;
        cin>>t;
        int co=1;
        while(t--){
    
            cin>>n>>m;
            sum=0;
            memset(mapp,INF,sizeof(mapp));
            memset(flag,0,sizeof(flag));
            memset(dis,0,sizeof(dis));
            memset(diss,0,sizeof(diss));
            for(int i=0;i<m;i++){
                    int x,y,s;
                    cin>>x>>y>>s;
                    if(flag[x][y]==0){
                            flag[x][y]=flag[y][x]=1;
                            mapp[x][y]=mapp[y][x]=s;
                    }
                    else{
                            sum++;
                            if(mapp[x][y]>s){
                                    mapp[x][y]=mapp[y][x]=s;
                            }
                    }
            }
            Floyd();
            int num=0;
            /*for(int i=1;i<=n;i++){
                    for(int j=1;j<=n;j++){
                            if(dis[i][j]==1&&flag[i][j]==1&&diss[i][j]!=1){
                                    sum++;
                            }
                    }
            }*/
            cout<<"Case "<<co++<<": "<<sum<<endl;
    
        }
        return 0;
    }
    

      

  • 相关阅读:
    ubuntu21.10(linux): 安装和使用ab(ApacheBench, Version 2.3)
    centos8(linux): nohup生成的日志切分
    EMR StarRocks 极速数据湖分析原理解析
    专访香侬科技:致力于让世界听到中文NLP的声音
    数智科技护航微出行
    无影云电脑支持企业快速实现居家办公
    深度解读「无影云电脑远程办公解决方案」
    系统性能分析从入门到进阶
    车脉科技:业内首创“车企体验式营销”
    基于Confluent+Flink的实时数据分析最佳实践
  • 原文地址:https://www.cnblogs.com/luowentao/p/9000643.html
Copyright © 2020-2023  润新知