• POJ


    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

    Input

    * Line 1: Two integers: T and N 

    * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

    Output

    * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

    Sample Input

    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100

    Sample Output

    90

    Hint

    INPUT DETAILS: 

    There are five landmarks. 

    OUTPUT DETAILS: 

    Bessie can get home by following trails 4, 3, 2, and 1.

    很简单dijkstra就可以过,入门级的题目,这个题建议不要抄模板,直接自己敲,就是用来练习最短路的,模板始终不是自己的。

    #include<iostream>
    #include<queue>
    #include<algorithm>
    #include<set>
    #include<cmath>
    #include<vector>
    #include<map>
    #include<stack>
    #include<bitset>
    #include<cstdio>
    #include<cstring>
    #define Swap(a,b) a^=b^=a^=b
    #define cini(n) scanf("%d",&n)
    #define cinl(n) scanf("%lld",&n)
    #define cinc(n) scanf("%c",&n)
    #define cins(s) scanf("%s",s)
    #define coui(n) printf("%d",n)
    #define couc(n) printf("%c",n)
    #define coul(n) printf("%lld",n)
    #define speed ios_base::sync_with_stdio(0)
    #define Max(a,b) a>b?a:b
    #define Min(a,b) a<b?a:b
    #define mem(n,x) memset(n,x,sizeof(n))
    using namespace std;
    typedef long long ll;
    const int INF=0x3f3f3f3f;
    const int maxn=1e3+10;
    const double esp=1e-9;
    //-------------------------------------------------------//
    
    int n,m; //n个节点,m条边
    int dis[maxn][maxn];
    bool vis[maxn];
    int d[maxn];
    inline void dijstra();
    int main()
    {
        mem(dis,0x3f);
        mem(vis,0);
        mem(d,0x3f);
        for(int i=1; i<=n; i++)dis[i][i]=0;
        cini(m),cini(n);//输入边数//点数
        for(int i=0; i<m; i++)
        {
            int x,y,z;
            cini(x),cini(y),cini(z);
            dis[x][y]=min(dis[x][y],z);
            dis[y][x]=min(dis[y][x],z);
            //cout<<dis[x][y]<<endl;
        }
        dijstra();
        cout<<d[n]<<endl;
    }
    inline void dijstra()
    {
        d[1]=0;
        for(int i=1; i<=n; i++)
        {
            int x=0;
            for(int j=1; j<=n; j++)
                if(!vis[j]&&(d[j]<d[x]||x==0))x=j;
    
            vis[x]=1;
            for(int j=1;j<=n;j++)
                d[j]=min(d[j],d[x]+dis[x][j]);
    
        }
    }
    
  • 相关阅读:
    内置函数详解
    lambda函数
    第八章(5)
    第八章(4)
    第八章(3)
    第八章(2)
    第八章(1)
    第七章(3)
    第七章(2)
    第七章(1)
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798803.html
Copyright © 2020-2023  润新知