• 1047 Student List for Course


    Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of students, and K (≤), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤) which is the number of courses that this student has registered, and then followed by Ccourse numbers. For the sake of simplicity, the courses are numbered from 1 to K.

    Output Specification:

    For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

    Sample Input:

    10 5
    ZOE1 2 4 5
    ANN0 3 5 2 1
    BOB5 5 3 4 2 1 5
    JOE4 1 2
    JAY9 4 1 2 5 4
    FRA8 3 4 2 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 5 4 2
    LOR6 4 2 4 1 5
    

    Sample Output:

    1 4
    ANN0
    BOB5
    JAY9
    LOR6
    2 7
    ANN0
    BOB5
    FRA8
    JAY9
    JOE4
    KAT3
    LOR6
    3 1
    BOB5
    4 7
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1
    5 9
    AMY7
    ANN0
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1
    
    /*
        Name:
        Copyright:
        Author:  流照君
        Date: 2019/8/4 17:02:05
        Description:
    */
    #include <iostream>
    #include<string>
    #include <algorithm>
    #include <vector>
    using namespace std;
    const int inf=40040;
    string name[inf];
    vector<int> course[inf];
    int cmp(int a,int b)
    {
        return name[a]<name[b];
    }
    int main(int argc, char** argv)
    {
        //freopen("in.txt", "r", stdin);
        //freopen("out.txt", "w", stdout);
        int n,m,cnt,s;
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin>>name[i]>>cnt;
            for(int j=0;j<cnt;j++)
            {
                cin>>s;
                course[s].push_back(i);
            }
        }
        for(int i=1;i<=m;i++)
        {
            cout<<i<<" "<<course[i].size()<<endl;
            sort(course[i].begin(),course[i].end(),cmp);
            for(int j=0;j<course[i].size();j++)
            {
                cout<<name[course[i][j]]<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    About Me
    洛谷 P2633 Count on a tree
    【题解】牛客编程巅峰赛S1赛季第1场
    洛谷 P4132 [BJOI2012]算不出的等式
    洛谷 P5970 [POI2016]Nim z utrudnieniem
    DP没入门就入土
    洛谷 P4042 [AHOI2014/JSOI2014]骑士游戏
    洛谷 P3592 [POI2015]MYJ
    51Nod 1683 最短路
    51Nod 1327 棋盘游戏
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11299448.html
Copyright © 2020-2023  润新知