• POJ 3673:Cow Multiplication


    Cow Multiplication
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12210   Accepted: 8509

    Description

    Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A andB. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

    Input

    * Line 1: Two space-separated integers: A and B.

    Output

    * Line 1: A single line that is the A*B in Bessie's style of multiplication.

    Sample Input

    123 45
    
    

    Sample Output

    54


    还是水题。。。字符串按位乘,再相加。

    代码:

    #include <iostream>
    #include <cmath>
    #include <algorithm>
    #include <string>
    #include <cstring>
    using namespace std;
    
    int main()
    {
    	string m,n;
    	cin>>m>>n;
    
    	int i,j,result=0;
    	for(i=0;i<m.length();i++)
    	{
    		for(j=0;j<n.length();j++)
    		{
    			result += (m[i]-'0')*(n[j]-'0');
    		}
    	}
    	cout<<result<<endl;
        return 0;
    }



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    bzoj 2002 [Hnoi2010]Bounce 弹飞绵羊
    【无图慎入】Link Cut Tree 总结
    cogs1889 [SDOI2008]Cave 洞穴勘测 link-cut tree
    Codeforces Round #452 (Div. 2)
    【正经向】NOIP2017烤后总结
    cogs1772 [国家集训队2010]小Z的袜子
    noip2017普及题解
    noip2017 TG 游记
    noip2017 PJ AK记
    jzoj5341 捕老鼠
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785857.html
Copyright © 2020-2023  润新知