• hdoj_2594Simpsons’ Hidden Talents


    Simpsons’ Hidden Talents

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1599    Accepted Submission(s): 589


    Problem Description
    Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
    Marge: Yeah, what is it?
    Homer: Take me for example. I want to find out if I have a talent in politics, OK?
    Marge: OK.
    Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
    in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
    Marge: Why on earth choose the longest prefix that is a suffix???
    Homer: Well, our talents are deeply hidden within ourselves, Marge.
    Marge: So how close are you?
    Homer: 0!
    Marge: I’m not surprised.
    Homer: But you know, you must have some real math talent hidden deep in you.
    Marge: How come?
    Homer: Riemann and Marjorie gives 3!!!
    Marge: Who the heck is Riemann?
    Homer: Never mind.
    Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
     

    Input
    Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
     

    Output
    Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
    The lengths of s1 and s2 will be at most 50000.
     

    Sample Input
    clinton homer riemann marjorie
     

    Sample Output
    0 rie 3
    利用next数组的性质,以Text[i]结尾的j个字符恰好与pat数组的前j个字符匹配

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 50005 * 2;
    int Next[MAXN];
    char text[MAXN], pat[MAXN];
    void get_next()
    {
    	int i = 0, j = -1;
    	int lenp = strlen(pat);
    	Next[0] = -1;
    	while(i < lenp)
    	{
    		if(j == -1 || pat[i] == pat[j])
    		{
    			i++;
    			j++;
    			Next[i] = j;
    		}
    		else
    		{
    			j = Next[j];
    		}
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int lenp, len;
    	while (scanf("%s %s", pat, text) != EOF)
    	{
    		len = min(strlen(pat), strlen(text));
    		memset(Next, 0, sizeof(Next));
    		strcat(pat, text);
    		lenp = strlen(pat);
    		get_next();
    		if(Next[lenp] >= len)
    		{
    			for(int i = 0; i < len; i++)
    			{
    				printf("%c", pat[i]);
    			}
    			printf(" %d\n", len);
    		}
    		else if(Next[lenp] != 0)
    		{
    			for(int i = 0; i < Next[lenp]; i++)
    			{
    				printf("%c", pat[i]);
    			}
    			printf(" %d\n", Next[lenp]);
    		}
    		else
    		{
    			printf("0\n");
    		}
    		
    	}
    	return 0;
    }

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 50005;
    int Next[MAXN];
    int ans[MAXN];
    char text[MAXN], pat[MAXN];
    void get_next()
    {
    	int i = 0, j = -1;
    	int length = strlen(pat);
    	Next[0] = -1;
    	while(i < length)
    	{
    		if(j == -1 || pat[i] == pat[j])
    		{
    			i++;
    			j++;
    			Next[i] = j;
    		}
    		else
    		{
    			j = Next[j];
    		}
    	}
    }
    void kmp()
    {
    	int lent = strlen(text);
    	int lenp = strlen(pat);
    	get_next();
    	int i = 0, j = 0;
    	ans[0] = 0;
    	while(i < lent)
    	{
    		if(j == -1 || text[i] == pat[j])
    		{
    			i++;
    			j++;
    			ans[i] = j;
    		}
    		else
    		{
    			j = Next[j];
    		}
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	while (scanf("%s %s", pat, text) != EOF)
    	{
    		int len = strlen(text);
    		kmp();	
    		if(ans[len] == 0)
    		{
    			printf("0\n");
    		}
    		else
    		{
    			for (int i = 0; i < ans[len]; i++)
    			{
    				printf("%c", pat[i]);
    			}
    			printf(" %d\n", ans[len]);
    		}
    
    	}
    	return 0;
    }



  • 相关阅读:
    软件的安全性应从哪几个方面去测试?
    目前主要的测试用例设计方法是什么?
    什么是软件质量?
    软件配置管理的作用?软件配置包括什么?
    什么是软件测试?软件测试的目的与原则
    软件生存周期及其模型是什么?
    软件的概念和特点?软件复用的含义?构件包括哪些?
    一台客户端有三百个客户与三百个客户端有三百个客户对服务器施压,有什么区别?
    在搜索引擎中输入汉字就可以解析到对应的域名,请问如何用LoadRunner进行测试。
    测试08
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834974.html
Copyright © 2020-2023  润新知