Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41179 Accepted Submission(s): 8827
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
Author
CHEN, Shunbao
Source
Recommend
JGShining
这题看起来比较简单,但是也容易错的.但是我发现网上很多这道题的解发都是有问题的,有的可以通过,是数据不多的原因。
比如A=7,B=7,n=50,或者51,明显结果应该是0,但是有的结果出来时1的。
#include<stdio.h>
int main()
{
//freopen("test.in","r",stdin);
//freopen("test.out","w",stdout);
int A,B,i;
long n;
int f[201];
f[1]=f[2]=1;
while(scanf("%d %d %ld",&A,&B,&n))
{
if(A==0&&B==0&&n==0) break;
int cnt=0;
for(i=3;i<=200;i++)//打表找到周期
{
f[i]=(A*f[i-1]+B*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)break;
if(f[i]==0&&f[i-1]==0){cnt=1;break;}//这里有个小陷阱,如果A=7,B=7则后面都为0了
}
if(cnt){printf("0\n");continue;}
if(i>n){printf("%d\n",f[n]);continue;}
i-=2;//i为周期
n%=i;
if(n==0)n=i;
printf("%d\n",f[n]);
}
return 0;
}