成绩转换
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 173950 Accepted Submission(s): 76178
Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
Input
输入数据有多组,每组占一行,由一个整数组成。
Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
Sample Input
56
67
100
123
Sample Output
E
D
A
Score is error!
1 #include<cstdio> 2 using namespace std; 3 int main() 4 { 5 int x; 6 while(scanf("%d",&x)!=EOF) 7 { 8 if(x>=90 && x <=100) 9 { 10 printf("A "); 11 } 12 else if(x>=80 && x <=89) 13 { 14 printf("B "); 15 } 16 else if(x>=70 && x <=79) 17 { 18 printf("C "); 19 } 20 else if(x>=60 && x <=69) 21 { 22 printf("D "); 23 } 24 else if(x>=0 && x <=59) 25 { 26 printf("E "); 27 } 28 else 29 { 30 printf("Score is error! "); 31 } 32 } 33 return 0; 34 }