• HelloWorldForU 九度Online Judge


    题目描述:

    Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

    h    d
    e     l
    l      r
    lowo


    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

    输入:

    There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    输出:

    For each test case, print the input string in the shape of U as specified in the description.

    样例输入:
    helloworld!
    ac.jobdu.com
    样例输出:
    h   !
    e   d
    l   l
    lowor
    a    m
    c    o
    .    c
    jobdu.
    
    
    代码:
    #include <iostream>
    #include <string>
    
    using namespace std;
    
    
    int main(int argc, char** args) {
    	string s;
    	while (cin >> s && s.size() >= 5 && s.size() <= 80) {
    		int len = s.size();
    		int height = (len - 2) / 3;
    		int width = len - 2 * height;
    
    		for (int i = 0; i < height; ++ i) {
    			cout.setf(ios::left);
    			cout.width(width - 1);
    			cout << s[i];
    			cout << s[len - (i + 1)] << endl;
    
    			if (i == (height - 1)) {
    				string substr = s.substr(height, width);
    				cout << substr << endl;
    			}
    		}
    	}
    }
    

    代码没有提交过,不知道能不能AC。
  • 相关阅读:
    【npm】mac下node环境搭建
    pair求解迷宫的最短路径(bfs)
    dos窗口启动关闭Mysql
    二维差分模板
    一维差分模板
    DOS命令
    迷宫搜索dfs实现
    DFS 迷宫问题
    BFS广搜解决迷宫问题(跟着B站大佬手撸)
    蓝桥杯省赛模拟赛
  • 原文地址:https://www.cnblogs.com/java20130722/p/3206807.html
Copyright © 2020-2023  润新知