• ZOJ Problem Set -1259 Rails


    Rails

    Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

    There is a famous railway station in PopPush City. Country there is incredibly   hilly. The station was built in last century. Unfortunately, funds were extremely   limited that time. It was possible to establish only a surface track. Moreover,   it turned out that the station could be only a dead-end one (see picture) and   due to lack of available space it could have only one track.

    The local tradition is that every train arriving from the direction A continues   in the direction B with coaches reorganized in some way. Assume that the train   arriving from the direction A has N <= 1000 coaches numbered in increasing   order 1, 2, ..., N. The chief for train reorganizations must know whether it   is possible to marshal coaches continuing in the direction B so that their order   will be a1, a2, ..., aN. Help him and write a program that decides whether it   is possible to get the required order of coaches. You can assume that single   coaches can be disconnected from the train before they enter the station and   that they can move themselves until they are on the track in the direction B.   You can also suppose that at any time there can be located as many coaches as   necessary in the station. But once a coach has entered the station it cannot   return to the track in the direction A and also once it has left the station   in the direction B it cannot return back to the station.


    Input

      The input consists of blocks of lines. Each block except the last describes   one train and possibly more requirements for its reorganization. In the first   line of the block there is the integer N described above. In each of the next   lines of the block there is a permutation of 1, 2, ..., N. The last line of   the block contains just 0.

      The last block consists of just one line containing 0.


    Output

       The output contains the lines corresponding to the lines with permutations in   the input. A line of the output contains Yes if it is possible to marshal the   coaches in the order required on the corresponding line of the input. Otherwise   it contains No. In addition, there is one empty line after the lines corresponding   to one block of the input. There is no line in the output corresponding to the   last ``null'' block of the input.


    Sample Input

    5
      1 2 3 4 5
      5 4 1 2 3
      0
      6
      6 5 4 3 2 1
      0
      0


    Sample Output

    Yes
      No

    Yes


                                            Source: Central Europe 1997

    AC代码:

    #include<iostream>
    #include<stdio.h>
    #include<stack>
    using namespace std;
    int main()
    {
     int m,n;
     //int cas=0;
     while(cin>>n)
     {
       if(n==0)break;
       //cas++;
      // if(cas!=1)cout<<endl;
       while(1)
       {
      stack<int>s;
      bool flag=true;
      int j=1;
      bool quit=false;
      for(int i=1;i<=n;i++)
      {
       int t;cin>>t;
       if(t==0)
       {
        quit=true;
        break;
       }
       while(1)
       {
        if(s.empty()||s.top()!=t)
        {
         if(j>n)
         {
           flag=false;
           break;
         }
         s.push(j);
         j++;
        }
        else if(s.top()==t)
        {
         s.pop();
         break;
        }
       }
      }
      if(quit)
      {
       cout<<endl;
       break;
      }
      if(flag)cout<<"Yes"<<endl;
      else cout<<"No"<<endl;
      }
     }
    }

  • 相关阅读:
    转几篇关于反射的文章
    几篇并发的文章
    线程池的使用(转)
    深入理解java不可变对象(转)
    收集的书
    BeanPostProcessor(转)
    JDK的动态代理深入解析(Proxy,InvocationHandler)(转)
    Java中InputStream和String之间的转换方法
    linux的一些常用命令
    Linux下查看文件内容的命令
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366518.html
Copyright © 2020-2023  润新知