• ZOJ Problem Set


    ZOJ Problem Set - 2110
    Tempter of the Bone

    Time Limit: 2 Seconds                                    Memory Limit: 65536 KB                            

    The doggie found a bone in an ancient maze, which fascinated him a lot. However,   when he picked it up, the maze began to shake, and the doggie could feel the   ground sinking. He realized that the bone was a trap, and he tried desperately   to get out of this maze.

      The maze was a rectangle with sizes N by M. There was a door in the maze. At   the beginning, the door was closed and it would open at the T-th second for   a short period of time (less than 1 second). Therefore the doggie had to arrive   at the door on exactly the T-th second. In every second, he could move one block   to one of the upper, lower, left and right neighboring blocks. Once he entered   a block, the ground of this block would start to sink and disappear in the next   second. He could not stay at one block for more than one second, nor could he   move into a visited block. Can the poor doggie survive? Please help him.


    Input

      The input consists of multiple test cases. The first line of each test case   contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50),   which denote the sizes of the maze and the time at which the door will open,   respectively. The next N lines give the maze layout, with each line containing   M characters. A character is one of the following:

      'X': a block of wall, which the doggie cannot enter;
      'S': the start point of the doggie;
      'D': the Door; or
      '.': an empty block.

      The input is terminated with three 0's. This test case is not to be processed.


    Output

      For each test case, print in one line "YES" if the doggie can survive,   or "NO" otherwise.


    Sample Input

      4 4 5
      S.X.
      ..X.
      ..XD
      ....
      3 4 5
      S.X.
      ..X.
      ...D
      0 0 0


      Sample Output


      NO
      YES

    不减少递归条件就会TLE,使劲了各种手段、查题解,修改递归函数,调试了半天才过了。。。

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    char maze[10][10];
    int si,sj,ei,ej;
    int n,m,t;
    int flag;
    int dir[4][2]={{0,-1},{0,1},{-1,0},{1,0}};
    int abs(int num)
    {
    	if(num<0)return -1*num;
    	else return num;
    }
    void dfs(int i,int j,int ct)
    {
    	if(i<=0||i>n||j<=0||j>m)
    	{
    		return ;
    	}
    	else if(ct>t)return;
    	else if(i==ei&&j==ej&&ct==t)
    	{ 
    		//cout<<"========in 'D'======"<<endl;
    		//cout<<"i: "<<i<<" j: "<<j<<" ct: "<<ct<<endl;
    		//cout<<maze[i][j]<<endl;
    		//cout<<"========in 'D'======"<<endl;
    	    flag=true;
    		return;
    	}
    	int temp=(t-ct)-abs(i-ei)-abs(j-ej);//减少递归分支,以免超时 
    	//cout<<"temp: "<<temp<<endl;
    	if(temp<0||temp%2)return;
        for(int k=0;k<4;k++)
        {
        	//cout<<"k: "<<k<<endl;
        	if(maze[i+dir[k][0]][j+dir[k][1]]=='.')//检查周围的点是否是一个点    	{
        		//cout<<"i: "<<i<<" j: "<<j<<" ct: "<<ct<<endl; 
        		maze[i+dir[k][0]][j+dir[k][1]]='X';
        		dfs(i+dir[k][0],j+dir[k][1],ct+1);
    			maze[i+dir[k][0]][j+dir[k][1]]='.';
        		if(flag)return;
        		
        	}
        }
    	
    }
    int main()
    {
    	while(cin>>n>>m>>t)
    	{
    		if(n==0&&m==0&&t==0)break;
    		memset(maze,0,sizeof(maze));
    	    //memset(visit,0,sizeof(maze));
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=m;j++)
    			{
    				cin>>maze[i][j];
    				if(maze[i][j]=='S')
    				{
    					si=i;sj=j;
    					maze[i][j]='X';
    				}
    				else if(maze[i][j]=='D')
    				{
    					ei=i;ej=j;
    					maze[i][j]='.';
    				}
    			}
    		}
    		flag=false;
    		dfs(si,sj,0);
    		if(flag)
    		{
    			cout<<"YES"<<endl;
    		}
    		else cout<<"NO"<<endl;
    	}
    } 


     

  • 相关阅读:
    bash八大扩展一网打尽
    MySQL命令行导出数据库
    Windows 7上的DirectX 11.1
    把KlayGE嵌入其他GUI框架
    KlayGE的资源载入系统
    学习路漫漫……
    写下我的第一篇Post,呵呵
    今天学习:CSS中的类class和标识id选择符(.和#号)
    Remove Duplicates from Unsorted List
    2012 TODO List
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366499.html
Copyright © 2020-2023  润新知