• HDU 1133 Buy the Ticket


    Buy the Ticket

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3286    Accepted Submission(s): 1366


    Problem Description
    The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

    Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

    Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person. 
    Note: initially the ticket-office has no money. 

    The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
     
    Input
    The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
     
    Output
    For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
     
    Sample Input
    3 0 3 1 3 3 0 0
     
    Sample Output
    Test #1: 6 Test #2: 18 Test #3: 180
     
    Author
    HUANG, Ninghai
     
    Recommend
    Eddy

    解题思路(转):( C(m+n, n) - C(m+n, m+1) ) * m! * n! 化简即 (m+n)! * (m-n+1) /(m+1)

    推導過程如下:

    m個人拿50n個人拿100
    1、如果n > m,那麼排序方法數為0,這一點很容易想清楚
    2、現在我們假設拿50的人用‘0’表示,拿100的人用‘1’表示。
    如果有這麼一個序列0101101001001111
    當第K個位置出現1的個數多餘0的個數時就是一個不合法的序列了
    假設m=4,n=3的一個序列是:0110100 。顯然,它不合法,現在我們把它稍微變化一下:
    把第二個1(這個1前面的都是合法的)後面的所有位0變成11變成0.
    就得到0111011這個序列1的數量多餘0的數量,顯然不合法,但現在的關鍵不是看這個序列是不是合法的
    關鍵是:他和我們的不合法序列0110100成一一對應的關係。
    也就是說任意一個不合法序列(m0n1),都可以由另外一個序列(n-10m+11)得到。
    另外我們知道,一个序列要麼是合法的,要麼是不合法的
    所以,合法序列數量 = 序列總數量 - 不合法序列的總量
    序列總數可以這樣計算 m+n個位置中,選擇n個位置出來填上1,所以是C(m+n,n).
    不合法序列的數量就是: m+n個位置中,選擇m+1個位置出來填上1,所以是C(m+n,m+1).
    然後每個人都是不一樣的,所以需要全排列m! * n!.
    所以最後的公式為:( C(m+n,n) - C(m+n,m+1) ) * m! * n!
    化簡即為:(m+n)!*(m-n+1)/(m+1)
     
    推廣:
    如果原來有p50元的話,那麼不合法的序列的數量應該是:任意一個不合法序列(m0n1),都可以由另外一個序列(n-10m+1+p1)得到,所以是m+n個位置中,選擇m+1+p個位置,出來填上1所以是C(m+n,m+1+p),接下來簡化就不推了
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    int fac[210][100];
    int res[100];
    
    void multiply(int a[],int k){   //大數乘小數
        int tmp=0;
        for(int i=99;i>=0;i--){
            tmp+=k*a[i];
            a[i]=tmp%10000;
            tmp/=10000;
        }
    }
    
    void Fact(){    //求階乘
        fac[0][99]=fac[1][99]=1;
        for(int i=2;i<=200;i++){
            memcpy(fac[i],fac[i-1],100*sizeof(int));
            multiply(fac[i],i);
        }
    }
    
    void divide(int a[],int k){  //大數除小數
        int tmp=0;
        for(int i=0;i<100;i++){
            tmp=tmp*10000+a[i];
            a[i]=tmp/k;
            tmp%=k;
        }
    }
    
    void Print(int a[]){
        int i=0;
        while(i<100 && a[i]==0) //去掉前導的0
            i++;
        printf("%d",a[i++]);
        while(i<100)
            printf("%04d",a[i++]);
        printf("\n");
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int m,n;
        int cases=0;
        Fact();
        while(~scanf("%d%d",&m,&n)){
            if(m==0 && n==0)
                break;
            printf("Test #%d:\n",++cases);
            if(n>m){
                printf("0\n");
                continue;
            }
            memcpy(res,fac[m+n],100*sizeof(int));
            multiply(res,m-n+1);
            divide(res,m+1);
            Print(res);
        }
        return 0;
    }
  • 相关阅读:
    H.265网页播放器EasyPlayer获取视频流正常,但是播放出现黑屏是什么原因?
    sql server设置允许远程连接的方法
    SQL Server 添加、修改和删除表格字段
    IDEA设置编辑器主题
    Idea中如何查看项目配置
    IDEA常用快捷键
    SQL Server : 18456报错
    SQL Server : 排序规则冲突collate Chinese_PRC_90_CI_AI
    excel表格如何设置下拉选项
    EXCEL插入图片批注
  • 原文地址:https://www.cnblogs.com/jackge/p/3055580.html
Copyright © 2020-2023  润新知