• HDU Simpsons’ Hidden Talents (KMP)


    Simpsons’ Hidden Talents

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 37   Accepted Submission(s) : 11
    Problem Description
    Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. Marge: Yeah, what is it? Homer: Take me for example. I want to find out if I have a talent in politics, OK? Marge: OK. Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton Marge: Why on earth choose the longest prefix that is a suffix??? Homer: Well, our talents are deeply hidden within ourselves, Marge. Marge: So how close are you? Homer: 0! Marge: I’m not surprised. Homer: But you know, you must have some real math talent hidden deep in you. Marge: How come? Homer: Riemann and Marjorie gives 3!!! Marge: Who the heck is Riemann? Homer: Never mind. Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
     
    Input
    Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
     
    Output
    Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. The lengths of s1 and s2 will be at most 50000.
     
    Sample Input
    clinton
    homer
    riemann
    marjorie
     
    Sample Output
    0
    rie 3
     
    Source
    HDU 2010-05 Programming Contest
     
     

    题意前面一堆废话,就是问给出两个字符串s1和s2,问s1的前缀和s2的后缀最大匹配的数量,

    这很容易让人想到KMP中求next数组的方法,所以这里可以把s1,s2连接起来,strcat(s1,s2)该函数的作用就是把s2连接到s1的末端

    连接完之后就是对串s1进行求next代码详见kMP,接下来就是判断next[k]与len1和len2的关系

    如果next[k]大于len1或len2,则继续回溯k=next[k];

    这样判断next[k]是否为零,为零则没有匹配,不为零输出next[k]即是最大的匹配数

     

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=50010;
    
    int next[maxn<<1];
    char s1[maxn<<1],s2[maxn];
    
    void getnext(char *s){
        int len=strlen(s);
        int i=0,j=-1;
        next[0]=-1;
        while(i<len){
            if(j==-1 || s[i]==s[j]){
                i++;j++;
                next[i]=j;
            }else
                j=next[j];
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%s%s",s1,s2)){
            int len1=strlen(s1);
            int len2=strlen(s2);
            strcat(s1,s2);
            getnext(s1);
            int k=len1+len2;
            while(next[k]>len1 || next[k]>len2)
                k=next[k];
            if(next[k]==0)
                printf("0\n");
            else{
                for(int i=0;i<next[k];i++)
                    printf("%c",s1[i]);
                printf(" %d\n",next[k]);
            }
        }
        return 0;
    }
    #include<iostream>
    #include<cstdiO>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=50010;
    
    int next[maxn];
    char s1[maxn],s2[maxn];
    
    void getnext(int len2){
        int i=0,j=-1;
        next[0]=-1;
        while(i<len2){
            if(j==-1 || s2[i]==s2[j]){
                i++;j++;
                next[i]=j;
            }else
                j=next[j];
        }
    }
    
    void KMP(int len1,int len2){
        int i=0,j=0;
        getnext(len2);
        while(i<len1){  //不能写成while(i<len1 && j<len2)
            if(j==-1 || s1[i]==s2[j]){
                i++;j++;
            }else
                j=next[j];
        }
        if(j!=0){
            for(int k=0;k<j;k++)
                printf("%c",s2[k]);
            printf(" %d\n",j);
        }else
            printf("0\n");
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%s%s",s2,s1)){
            int len1=strlen(s1);
            int len2=strlen(s2);
            KMP(len1,len2);
        }
        return 0;
    }
  • 相关阅读:
    Java数据库——CallableStatement接口
    Java数据库——处理大数据对象
    Java数据库——PreparedStatement接口
    Java数据库——ResultSet接口
    Java数据库——连接关闭、增删改查
    Ubuntu下的MySQL安装
    JDBC
    注释(Annotation)
    类的生命周期
    Java反射机制<2>
  • 原文地址:https://www.cnblogs.com/jackge/p/3032163.html
Copyright © 2020-2023  润新知