• HDU 1063 Exponentiation


    Exponentiation

    Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4973    Accepted Submission(s): 1353

    Problem Description
    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 
    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 
     
    Input
    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
     
    Output
    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.
     
    Sample Input
    95.123 12
    0.4321 20
    5.1234 15
    6.7592 9
    98.999 10
    1.0100 12
     
    Sample Output
    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201
     
    Source
     
    Recommend
    PrincetonBoy
     
     
     

    a=a.stripTrailingZeros();                     //除去后导零         

    a=a.pow(n);                                

    ans=a.toPlainString();                  //toString()是以科学计数法输出

     

    import java.math.BigDecimal;
    import java.util.Scanner;
    
    
    public class Main{
        public static void main(String[] args){
            BigDecimal a;
            int n;
            String ans;
            Scanner cin = new Scanner(System.in);
            while(cin.hasNext()){
                a = cin.nextBigDecimal();
                n = cin.nextInt();
                a = a.pow(n);
                a = a.stripTrailingZeros();
                ans = a.toPlainString();
                if(ans.charAt(0) == '0')
                    System.out.println(ans.substring(1));
                else 
                    System.out.println(ans);
            }
        }
    }
  • 相关阅读:
    P1308 统计单词数
    P1055 ISBN号码
    InterlockedCompareExchange 原子操作
    InterlockedCompareExchange 原子操作
    VS2015 定位内存泄露
    VS2015 定位内存泄露
    const volatile mutable修饰变量的区别
    const volatile mutable修饰变量的区别
    HWND、HANDLE、HMODULE、HINSTANCE的区别
    CodeIgniter框架中关于URL重写(index.php)的二三事
  • 原文地址:https://www.cnblogs.com/jackge/p/2989993.html
Copyright © 2020-2023  润新知