• TOJ 1547


    1547.   To and Fro
    Time Limit: 1.0 Seconds   Memory Limit: 65536K
    Total Runs: 885   Accepted Runs: 692



    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down

    t o i o y
    h p k n n
    e l e a i
    r a h s g
    e c o n h
    s e m o t
    n l e w x
    

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character 'x' to pad the message out to make a rectangle, although he could have used any letter.

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

    toioynnkpheleaigshareconhtomesnlewx

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 ... 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0
    

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab
    
    #include <iostream>
    #include <cstring>
    using namespace std;
    int main()
    {
        int i,j,k,T;
        char s[205];
        while(cin>>T,T)
        {
            memset(s,0,sizeof(s));
            cin>>s;
            int len = strlen(s);
            //二维字符数组申请 
            int row = len/T;
            int col = T;
            char **str = new  char *[row];//  new  (char *)[row]会在编译器里CE 
            for(i=0;i<row;i++)
                str[i] = new char[col];
            k = 0;
            for(i=0;i<row;i++)
            if((i&1)==0)//行号为0,2,4,加上括号,否则,恰好相反,汗 
            {
                for(j=0;j<col;j++)
                    str[i][j] = s[k++]; 
            }
            else
            {
                for(j=col-1;j>=0;j--)
                    str[i][j] = s[k++];
            }
            /*
            for(i=0;i<row;i++)
            {
                for(j=0;j<col;j++)
                    cout<<str[i][j];
                cout<<endl;
            }
            */
            //按要求输出
            for(i=0;i<col;i++)
                for(j=0;j<row;j++)
                    cout<<str[j][i];//注意不是str[i][j] 
            cout<<endl;
            //释放 
            for(i=0;i<row;i++)
                delete []str[i];
            delete []str;
        }
        //system("pause");
        return 0;
    }
             
            
            
    
  • 相关阅读:
    CSS边框,背景,边距,溢出
    数字电子技术课程设计之基于触发器的三位二进制同步减法计数器无效态000/110
    集成电路版图与工艺课程设计之用CMOS实现Y=AB+C电路与版图
    金属磁记忆传感器封装
    基于FPGA 的8b10b编解码电路前端电路设计
    Css颜色和文本字体
    Css中的选择器
    Css基本语法及页面引用
    65 插入排序
    63 散列表的查找
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2640588.html
Copyright © 2020-2023  润新知