• poj 1273 裸 网络流 (dinic)


    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.  Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.  Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
    

    Sample Output

    50



    裸的 dinic 代码如下... 可做模板 orzzzz
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<deque>
    #include<queue>
    #include<stack>
    #include<map>
    #include<algorithm>
    #include<vector>
    #define INFINFE 999999999
    #define N 300
    using namespace std;
    int  G[300][300];
    bool visited[300];
    int  layer[300];
    int  n,m;
    bool countlayer()
    {
       // cout<<"***"<<endl;
        //int Layer=0;
        deque<int>q;
        memset(layer,0xff,sizeof(layer));
        layer[1]=0;
        q.push_back(1);
        while(!q.empty())
        {
            int v=q.front();
            q.pop_front();
            for(int j=1; j<=m; j++)
            {
                if(G[v][j]>0&&layer[j]==-1)
                {
                layer[j]=layer[v]+1;
                if(j==m)
                    return true;
                else
                    q.push_back(j);
            }
          }
        }
        return false;
    }
    int Dinic()
    {
        int i;
        //int s;
        int nmaxflow=0;
        deque<int>q;
        while(countlayer())
        {
            while(!q.empty())
                q.pop_back();
            q.push_back(1);
            memset(visited,0,sizeof(visited));
            visited[1]=1;
    
            while(!q.empty())
            {
                int nd=q.back();
                if(nd==m)
                {
                    int nminc=INFINFE;
                    int nminc_vs;
                    for(unsigned int i=1; i<q.size(); i++)
                    {
                        int vs=q[i-1];
                        int ve=q[i];
                        if(G[vs][ve]>0)
                        {
                            if(nminc>G[vs][ve])
                            {
                                nminc=G[vs][ve];
                                nminc_vs=vs;
                            }
                        }
                    }
                    nmaxflow+=nminc;
                    for(unsigned int i=1; i<q.size(); i++)
                    {
                        int vs=q[i-1];
                        int ve=q[i];
                        G[vs][ve]-=nminc;
                        G[ve][vs]+=nminc;
                    }
                    while(!q.empty()&&q.back()!=nminc_vs)
                    {
                        visited[q.back()]=0;
                        q.pop_back();
                    }
                }
                else
                {
                    for(i=1; i<=m; i++)
                    {
                        if(G[nd][i]>0&&layer[i]==layer[nd]+1&&!visited[i])
                        {
                            visited[i]=1;
                            q.push_back(i);
                            break;
                        }
                    }
                    if(i>m)
                        q.pop_back();
                }
            }
        }
        return nmaxflow;
    }
    int main()
    {
        while(cin>>n>>m)
        {
            int i;
            int s,e,c;
            memset(G,0,sizeof(G));
            for(i=0; i<n; i++)
            {
                cin>>s>>e>>c;
                G[s][e]+=c;
            }
            cout<<Dinic()<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    看了关于全职女性的文字,我想到了一些事情
    通过一个大型项目来学习分布式算法(6)
    IO模式——同步(堵塞、非堵塞)、异步
    湖南省第九届大学生计算机程序设计竞赛 高桥和低桥
    为什么我的ECSHOP出现报错改正确了还是没有反应?
    wxWidgets刚開始学习的人导引(2)——下载、安装wxWidgets
    1096. Consecutive Factors (20)
    POJ 2955 Brackets
    (转载)单调栈题目总结
    20140708郑州培训第二题Impossible Game
  • 原文地址:https://www.cnblogs.com/hsd-/p/4685599.html
Copyright © 2020-2023  润新知