• 1024. Palindromic Number (25)


    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3
    

    Sample Output 1:

    484
    2
    

    Sample Input 2:

    69 3
    

    Sample Output 2:

    1353
    3
    

     题目大意:求一个数是否是回文数,如果不是,则将与其反转数相加后,再次判断是否是回文数,以此类推。

     解题:好几次没把握住数据长度,int-long-long long发现都不够,最后只能用字符型!无奈脸,从题目中推出10^10,进行100次叠加,数据可能是10^20,超过long long 的10^19;

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    string add(string s,string rev){
    	string s1;
    	int length = s.size();
    	int i;
    	int index = 0;
    	int sum;
    	for(i=length-1;i>=0;i--){
    		sum = s[i] + rev[i] - '0' - '0' +index;
    		s1.insert(s1.begin(),sum%10+'0');
    		index = sum/10;
    	}
    	if(index){
    		s1.insert(s1.begin(),index+'0');
    	}
    	return s1;
    }
    int palindromic(string& s,string& rev){
    	rev = s;
    	reverse(rev.begin(),rev.end());
    	if(s == rev){
    		return true;
    	}
    	s = add(s,rev);
    	return false;
    }
    int main(){
    	string s,rev;
    	int k;
    	cin>>s>>k;
    	int i=0;
    	while(i < k){
    		if(palindromic(s,rev)){
    			break;
    		}
    		i++;
    	}
    	cout<<s<<endl<<i<<endl;
    	return 0;
    }
    

      

  • 相关阅读:
    第03组 Beta冲刺(2/5)
    2019 SDN上机第6次作业
    第03组 Beta冲刺(1/5)
    2019 SDN上机第5次作业
    SDN课程阅读作业(2)
    2019 SDN上机第4次作业
    第05组 团队Git现场编程实战
    第05组 团队项目-需求分析报告
    团队项目-选题报告
    第07组 Alpha事后诸葛亮
  • 原文地址:https://www.cnblogs.com/grglym/p/7665877.html
Copyright © 2020-2023  润新知