• [POJ] 1456 Supermarket


    Supermarket
    Time Limit: 2000MS      Memory Limit: 65536K
    Total Submissions: 14630        Accepted: 6648
    Description
    
    A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
    For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 
    
    
    Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 
    Input
    
    A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
    Output
    
    For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
    Sample Input
    
    4  50 2  10 1   20 2   30 1
    
    7  20 1   2 1   10 3  100 2   8 2
       5 20  50 10
    Sample Output
    
    80
    185
    Hint
    
    The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
    Source
    
    Southeastern Europe 2003

    贪心思想,优先卖出最贵的商品,尽量往后安排,使其具有决策包容性。
    并查集维护一个时间最早的可用时间。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    const int MAXN=10010;
    
    struct item{
        int val,tim;
        bool operator<(item y) const {
            return val > y.val ;
        } 
    }it[MAXN];
    
    int fa[MAXN];
    int fnd(int x){
        return x==fa[x]?x:fa[x]=fnd(fa[x]);
    }
    void cat(int x,int y){
        x=fnd(x);
        y=fnd(y);
        fa[y]=x;
    }
    
    int n;
    
    void slove(){
        int ans=0;
        for(int i=1;i<=n;i++)
            cin>>it[i].val>>it[i].tim ;
        for(int i=1;i<=10005;i++) fa[i]=i;
        sort(it+1,it+1+n);
        for(int i=1;i<=n;i++){
            int v=it[i].tim;
            int nv=fnd(v);
            if(nv<=0) continue;
            cat(nv-1,nv);
            ans+=it[i].val;
        }
        cout<<ans<<endl;
    }
    
    int main(){
        while(cin>>n) slove();
    }

    本文来自博客园,作者:GhostCai,转载请注明原文链接:https://www.cnblogs.com/ghostcai/p/9247471.html

  • 相关阅读:
    Perl Language 从入门到放弃 All In One
    Linux shell command line editor All In One
    TypeScript infer keyword All In One
    垂钓图解教程: 鱼钩 All In One
    CSS `@fontface` & fontfamily All In One
    Linux bash sed command All In One
    YouTube 标识名 All In One
    Leetcode 面试题 16.15. 珠玑妙算
    Leetcode 1385. 两个数组间的距离值
    Leetcode 984. 不含 AAA 或 BBB 的字符串(网友思路)
  • 原文地址:https://www.cnblogs.com/ghostcai/p/9247471.html
Copyright © 2020-2023  润新知