• Catch That Cow(广度优先搜索_bfs)


    
    Catch That Cow
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 48036   Accepted: 15057

    Description

    Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

    * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
    * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

    If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

    Input

    Line 1: Two space-separated integers: N and K

    Output

    Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    Sample Input

    5 17

    Sample Output

    4
    
    
    题意:输入两个数n,k。求从n到k最少走多少步。能够前进1后退1或者当前的位置*2。
    
    
    #include <stdio.h>
    #include <string.h>
    #include <stdlib.h>
    #include <algorithm>
    using namespace std;
    struct node
    {
        int x;//当前位置
        int ans;//走的步数
    }q[1000010];
    int vis[1000010];//标记变量,该点是否被訪问;
    int jx[]={-1,1};//后退1或者前进1。
    struct node t,f;
    int n,k;
    void bfs()
    {
         int i;
         int s=0,e=0;//指针模拟队列。

    往队列加e++ 往队列里提出数s++ memset(vis,0,sizeof(vis)); t.x=n;//当前初始位置 vis[t.x]=1;//标记为1代表訪问过。 t.ans=0;//初始位置步数为0; q[e++]=t;//把当前步数加人队列 while(s<e)//当队列不为空 { t=q[s++];//提出 if(t.x==k)//假设该数正好等于目标位置直接输出步数 { printf("%d ",t.ans); break; } for(i=0;i<3;i++)//i=0后退一步,i=1前进一步。i=2此时的位置*2; { if(i==2) { f.x=t.x*2; } else { f.x=t.x+jx[i]; } if(f.x>=0&&f.x<=100000&&!vis[f.x]) { f.ans=t.ans+1; q[e++]=f; vis[f.x]=1; } } } } int main() { while(~scanf("%d %d",&n,&k)) { bfs(); } return 0; }


  • 相关阅读:
    poj2679
    poj2709
    poj1521
    poj2054
    静脉曲张病案
    眩晕耳鸣病案
    声嘶治验
    甘露消毒丹治疗高热不退一例
    黄芩汤加减治疗腹痛一例
    自残症治愈案
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/6764021.html
Copyright © 2020-2023  润新知