• POJ 3903:Stock Exchange(裸LIS + 二分优化)


    http://poj.org/problem?id=3903

    Stock Exchange
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5983   Accepted: 2096

    Description

    The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

    Input

    Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).  White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

    Output

    The program prints the length of the longest rising trend.  For each set of data the program prints the result to the standard output from the beginning of a line.

    Sample Input

    6 
    5 2 1 4 5 3 
    3  
    1 1 1 
    4 
    4 3 2 1

    Sample Output

    3 
    1 
    1

    Hint

    There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
     
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    #include<iostream>
    #include <string>
    #include <cmath>
    using namespace std;
    //LIS+二分优化  O(nlogn)
    //参考:http://www.cnblogs.com/ziyi--caolu/p/3227121.html
    int a[100005];
    
    int main()
    {
        int n;
        while(cin>>n){
            int k=1,in;
            scanf("%d",a+1);
            for(int i=2;i<=n;i++){
                scanf("%d",&in);
                if(in>a[k]) a[++k]=in;
                else{
                    int l=1,r=k,mid;
                    while(l<r){
                        mid=(l+r)/2;
                        if(a[mid]<in) l=mid+1;
                        else r=mid;
                    }
                    a[l]=in;
                }
            }
            cout<<k<<endl;
        }
        return 0;
    }

     

    2016-05-29

  • 相关阅读:
    看过设计模式第一章的心得
    支付宝支付过程填坑
    C# 合并只要有交集的所有集合
    C#中的反射 Reflection
    动态更改配置文件
    六种弹窗
    Respone弹窗
    Aspose是一个很强大的控件,可以用来操作word,excel,ppt等文件
    使用ECharts报表统计公司考勤加班,大家加班多吗?
    排污许可管理条例-中华人民共和国国务院令第736号
  • 原文地址:https://www.cnblogs.com/fightfordream/p/5558696.html
Copyright © 2020-2023  润新知