• dp重拾-01背包--HDU 2602


    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     
    Sample Input
    1 5 10 1 2 3 4 5 5 4 3 2 1
     
    Sample Output
    14
     
    挺久没刷DP题了,先来一个01背包预热一下
    #include<iostream>
    #include<cstring>
    #include<stdlib.h>
    #include<stdio.h>
    using namespace std;
    int dp[1001][1001];
    int w[1001],v[1001],W,n;
    int max(int a,int b)
    {
        if(a>=b) return a;
        else return b;
    }
    void solve()
    {
        for(int i=n-1;i>=0;i--)
        {
            for(int j=0;j<=W;j++)
            {
                if(j<w[i]) dp[i][j]=dp[i+1][j];
                else dp[i][j]=max(dp[i+1][j],dp[i+1][j-w[i]]+v[i]);
            }
        }
        cout<<dp[0][W]<<endl;
    }
    
    int main()
    {
        int i,j,k;
        scanf("%d",&k);
        for(i=0;i<k;i++)
        {
            scanf("%d %d",&n,&W);
            for(j=0;j<n;j++)
            {
                scanf("%d",&v[j]);
            }
            for(j=0;j<n;j++)
            {
                scanf("%d",&w[j]);
            }
            solve();
            W=n=0;
            memset(dp,0,sizeof(dp));
            memset(v,0,sizeof(v));
            memset(w,0,sizeof(w));
        }
        return 0;
    }
    View Code
  • 相关阅读:
    员工转正考核
    前端高级技术考察
    前端基础技术考察
    高级前端评定表
    初级前端评定表
    前端工程师等级评定
    前端软实力
    Decode Ways
    深度学习在目标跟踪中的应用
    Interleaving String
  • 原文地址:https://www.cnblogs.com/dzzy/p/5036556.html
Copyright © 2020-2023  润新知