• PAT 1007 Maximum Subsequence Sum(最长子段和)


    1007. Maximum Subsequence Sum (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
    Sample Output:

    10 1 4

    动态规划求解最长子段和

    #include <iostream>
    #include <string.h>
    #include <stdlib.h>
    #include <stdio.h>
    #include <algorithm>
    #include <math.h>
    #include <queue>
    #include <map>
    #include <strstream>
    #include <string>
    
    using namespace std;
    #define MAX 10000
    int dp[MAX+5];
    int a;
    int n;
    int main()
    {
      int max;
      int begin;
      int end;
      int sum;
      int x;
      scanf("%d",&n);
      scanf("%d",&a);
      sum=a;
      max=a;
      begin=end=a;
      int s=a;
      x=a;
      for(int i=2;i<=n;i++)
      {
        scanf("%d",&a);
        if(sum>=0)
           sum+=a;
        else
        {
          sum=a;
          x=a;
        }
        if(max<sum)
        {
          max=sum;
          begin=x;
          end=a;
        }
      }
      if(max<0)
        cout<<0<<" "<<s<<" "<<a<<endl;
      else
          cout<<max<<" "<<begin<<" "<<end<<endl;
      return 0;
    }


  • 相关阅读:
    跳转练习
    从入门到自闭之Python--Redis
    从入门到自闭之Python--Django Rest_Framework
    从入门到自闭之Python--RESTful API规范与序列化
    从入门到自闭之Python--虚拟环境如何安装
    从入门到自闭之Python集合,深浅拷贝(大坑)
    从入门到自闭之Python编码
    从入门到自闭之Python字典如何使用
    从入门到自闭之Python列表,元祖及range
    从入门到自闭之Python整型,字符串以及for循环
  • 原文地址:https://www.cnblogs.com/dacc123/p/8228622.html
Copyright © 2020-2023  润新知