• POJ-2752


    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

    Step1. Connect the father's name and the mother's name, to a new string S. 
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    

    Source


    题解:简单的KMP只要得到Next[len]即可,然后依次输出

    AC代码为:

    #include<iostream>
    #include<cstring>
    using namespace std;
    const int Max = 400005;
     
    char str[Max];
    int len, Next[Max], ans[Max];
     
    void Get_next()
    {
        int l=strlen(str);
        Next[0]=Next[1]=0;
        
        for(int i=1;i<l;i++)
        {
        int j=Next[i];  
        while(j && str[i]!=str[j]) 
        j=Next[j];
    Next[i+1]=str[i]==str[j]? j+1:0; 
    }   
    }
     
    int main()
    {
        while(scanf("%s", str) != EOF)
    {
            len = strlen(str);
            Get_next();
            int i=len,cnt=0;
            
            while(Next[i]>0)
            {
            ans[cnt++]=Next[i];
            i = Next[i];
    }

    for(int i=cnt-1;i>=0;i--)
    {
    cout<<ans[i]<<" ";
    }
    cout<<len<<endl;
        }
        return 0;
    }



  • 相关阅读:
    TOP 100 SOFTWARE VENDORS (ZZ)
    数列总结函数——取余分析
    科克曼女生问题
    约瑟夫问题(猴子选王)——多种解法
    乒乓球与羽毛球不同发球规则下选手的胜率——概率论+程序分析
    Codeblocks快捷键
    常用陌生快捷键
    Dev使用技巧
    vueDemo补充
    vueDemo
  • 原文地址:https://www.cnblogs.com/csushl/p/9386584.html
Copyright © 2020-2023  润新知