• L贪心基础


    <span style="color:#330099;">/*
    L - 贪心 基础
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.
    
    The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.
    
    One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.
    
    The knights explained: "To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights' union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight's height."
    
    Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!
    
    Input
    The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon's heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.
    
    The last test case is followed by a line containing:
    
    0 0
    
    Output
    For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line:
    
    Loowater is doomed!
    
    Sample Input
    2 3
    5
    4
    7
    8
    4
    2 1
    5
    5
    10
    0 0
    Sample Output
    11
    Loowater is doomed!
    By Grant Yuan
    2014.7.14
    贪心
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    int m,n;
    int a[20001];
    int b[20001];
    int main()
    { int sum;
        while(1){sum=0;
          cin>>n>>m;
          if(m==0&&n==0)
             break;
          for(int i=0;i<n;i++)
             cin>>a[i];
        for(int j=0;j<m;j++)
            cin>>b[j];
          if(m<n){
               cout<<"Loowater is doomed!"<<endl;
               }
            else{
             sort(a,a+n);
             sort(b,b+m);
             int i=0;
               for(int j=0;j<m;j++)
                 {
                    if(b[j]>=a[i]){
                      i++;
                      sum+=b[j];}
                      if(i==n) break;}
                if(i==n) cout<<sum<<endl;
                else cout<<"Loowater is doomed!"<<endl;
            }}
            return 0;
    }
    </span>

  • 相关阅读:
    block和delegate的区别
    iOS真机测试友盟碰到错误linker command failed with exit code 1 (use -v to see invocation) 百度地图的检索失败 sqlite 错误码
    iOS国际化多语言设置
    获取本机ip地址
    iOS-Senior19-FMDB第三方应用
    iOS-Senior17-CoreAnimation动画
    iOS-Senior18-CocoPods的安装步骤
    iOS-Senior17-UIView动画
    iOS-Senior17-菊花风火轮(代码)
    iOS-Senior17-Gif动画图片(代码)
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254519.html
Copyright © 2020-2023  润新知