• poj 2538(简单题)


    题意是一个错误的键盘,输入的一个字母或字符时会变成这个字母或字符在键盘上位置右边的一个。 然后已知输出的字符,求你原本输入的是什么。

    有一种很土的办法就是一个字符一个字符的装换,但是这样不知道要用多少个if。

    可以把这这些字符存在一起 g[1000] ={"1234567890-=QWERTYUIOP[]\ASDFGHJKL;'ZXCVBNM,./"} ,这样只要找到了一个字符在这个g串中的位置i,然后g[i-1]就是我们要的哪个字符。 这样编程量就少了很多

    WERTYU
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7513   Accepted: 3538

    Description

     
    A common typing error is to place the hands on the keyboard one row to the right of the correct position. So "Q" is typed as "W" and "J" is typed as "K" and so on. You are to decode a message typed in this manner.

    Input

    Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (`)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

    Output

    You are to replace each letter or punctuation symbol by the one immediately to its left on the QWERTY keyboard shown above. Spaces in the input should be echoed in the output. 

    Sample Input

    O S, GOMR YPFSU/
    

    Sample Output

    I AM FINE TODAY.
    

    Source

     
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    using namespace std;
    
    char str[1100];
    char g[1100]={"1234567890-=QWERTYUIOP[]\ASDFGHJKL;'ZXCVBNM,./"};
    
    int main()
    {
        while(gets(str)!=0)
        {
            
            int len=strlen(str);
            for(int i=0;i<len;i++)
            {
                char tmp=str[i];
                int j;
                for(j=0;j<1100;j++)
                {
                    if(g[j]==tmp)
                        break;
                }
                if(j==1100) printf("%c",tmp);
                else
                printf("%c",g[j-1]);
            }
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    C#和C++除了语法上的差别外,还有什么其他的区别
    各种指针的的概览及造成原因
    批量操作Tomcat Shell脚本
    pi币pinetwork安装注册教程中文详细版【实操有效】
    Oracle分析函数
    Logger.Xml
    使用Redis / Zookeeper作为分布式锁的一些注意点
    Seata Server配置文件
    .gitignore忽略target无效
    MySql隔离级别:RU / RC / RR / S + 脏读 / 不可重复读 / 幻读 / 可重复读
  • 原文地址:https://www.cnblogs.com/chenhuan001/p/2990708.html
Copyright © 2020-2023  润新知