• hdu Minimum Inversion Number


    Minimum Inversion Number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5210    Accepted Submission(s): 3190

    Problem Description
    The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
    For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
    a1, a2, ..., an-1, an (where m = 0 - the initial seqence) a2, a3, ..., an, a1 (where m = 1) a3, a4, ..., an, a1, a2 (where m = 2) ... an, a1, a2, ..., an-1 (where m = n-1)
    You are asked to write a program to find the minimum inversion number out of the above sequences.
     
    Input
    The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
     
    Output
    For each case, output the minimum inversion number on a single line.
     
    Sample Input
    10 1 3 6 9 0 8 5 7 4 2
     
    Sample Output
    16
     
    Author
    CHEN, Gaoli
     
    Source
     
    Recommend
    Ignatius.L
     
    分析:线段树:单点更新,成段求和。模拟次序。
    #include<cstdio>
    #include<cstring>
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    int sum[1 << 14];
    int x[5010];
    
    inline int max(int a, int b) {
        return a > b ? a : b;
    }
    
    void pushup(int rt) {
        sum[rt] = (sum[rt << 1] + sum[rt << 1 | 1]);
    }
    
    void build(int l, int r, int rt) {
        if (l == r) {
            return;
        }
        int m = (l + r) >> 1;
        build(lson);
        build(rson);
    }
    
    void update(int p, int add, int l, int r, int rt) {
        if (l == r) {
            sum[rt] += add;
            return;
        }
        int m = (l + r) >> 1;
        if (p <= m)
            update(p, add, lson);
        else
            update(p, add, rson);
        pushup(rt);
    }
    
    int query(int L, int R, int l, int r, int rt) {
        if (L <= l && R >= r) {
            return sum[rt];
        }
        int m = (l + r) >> 1;
        int ans = 0;
        if (L <= m)
            ans = (ans + query(L, R, lson));
        if (R > m)
            ans = (ans + query(L, R, rson));
        return ans;
    }
    
    int main() {
        int n, i, j, ans, min;
        while (scanf("%d", &n) != EOF) {
            memset(sum, 0, sizeof (sum));
            ans = 0;
            build(0, n - 1, 1);
            for (i = 0; i < n; ++i) {
                scanf("%d", &x[i]);
                ans += query(x[i]+1, n - 1, 0, n - 1, 1);
                update(x[i], 1, 0, n - 1, 1);
            }
            min = ans;
            for (i = 0; i < n - 1; ++i) {
                ans = ans - x[i] - x[i] + n - 1;
                if (ans < min)
                    min = ans;
            }
            printf("%d\n", min);
        }
        return 0;
    }
  • 相关阅读:
    模拟赛T5 : domino ——深搜+剪枝+位运算优化
    校内模拟赛T5:连续的“包含”子串长度( nekameleoni?) —— 线段树单点修改,区间查询 + 尺取法合并
    C++[Tarjan求点双连通分量,割点][HNOI2012]矿场搭建
    C++二分图匹配基础:zoj1002 FireNet 火力网
    迭代加深搜索 C++解题报告 :[SCOI2005]骑士精神
    Linux 常用命令
    Microservices and exception handling in Java with Feign and reflection
    微服务摘要
    Javac编译与JIT编译
    GC调优思路
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2717004.html
Copyright © 2020-2023  润新知