• poj-3069-Saruman's Army


    http://poj.org/problem?id=3069

    Saruman's Army
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 4256Accepted: 2186

    Description

    Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

    Input

    The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n= −1.

    Output

    For each test case, print a single integer indicating the minimum number of palantirs needed.

    Sample Input

    0 3 10 20 20 10 7 70 30 1 7 15 20 50 -1 -1

    Sample Output

    2 4

    Hint

    In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

    In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

    解题思路:贪心,详情请看挑战程序设计竞赛(第二版)P45~P47

     1 #include <stdio.h>
     2 #include <stdlib.h>
     3 #include <string.h>
     4 
     5 int cmp(const void *a, const void *b){
     6     return  *(int *)a - *(int *)b;
     7 }
     8 
     9 int a[1010], R, N;
    10 
    11 void solve(){
    12     int i = 0, ans = 0;
    13     int s, e;
    14     while(i < N){
    15         //s是没有被覆盖的最左边的点的位置
    16         s = a[i++];
    17         //一直向右前进直到距s点的距离大于R的点
    18         while(i < N && a[i] <= s + R)   i++;
    19         
    20         //e是新加上标记的点的位置
    21         e = a[i - 1];
    22         //一直向右前进直到距e的距离大于R的点
    23         while(i < N && a[i] <= e + R)   i++;
    24         ans++;
    25     }
    26     printf("%d ", ans);
    27 }
    28 
    29 int main(){
    30     int i;
    31     while(scanf("%d %d", &R, &N) != EOF){
    32         if(R < 0 && N < 0){
    33             break;
    34         }
    35         for(i = 0; i < N; i++){
    36             scanf("%d", &a[i]);
    37         }
    38         qsort(a, N, sizeof(a[0]), cmp);
    39         solve();
    40     }
    41     return 0;

    42 } 

  • 相关阅读:
    Kerberos认证原理与环境部署
    大数据Hadoop之——EFAK安全认证实现(kafka+zookeeper)
    大数据Hadoop之——Kafka安全机制(Kafka SSL认证实现)
    大数据Hadoop之——Kafka Streams原理介绍与简单应用示例
    一文带你了解什么是CNCF&云原生
    大数据Hadoop之——Kafka鉴权认证(Kafka kerberos认证+kafka账号密码认证+CDH Kerberos认证)
    企业级日志系统架构——ELK(Elasticsearch、Filebeat、Kafka、Logstash、Kibana)
    Kafka原理介绍+安装+基本操作(kafka on k8s)
    Prometheus原理详解
    大数据Hadoop之——Zookeeper鉴权认证(Kerberos认证+账号密码认证)
  • 原文地址:https://www.cnblogs.com/angle-qqs/p/4085694.html
Copyright © 2020-2023  润新知