• 山东省第四届省赛 E-Mountain Subsequences


    Description

    Coco is a beautiful ACMer girl living in a very beautiful mountain. There are many trees and flowers on the mountain, and there are many animals and birds also. Coco like the mountain so much that she now name some letter sequences as Mountain Subsequences.

    A Mountain Subsequence is defined as following:

    1. If the length of the subsequence is n, there should be a max value letter, and the subsequence should like this, a1 < ...< ai < ai+1 < Amax > aj > aj+1 > ... > an

    2. It should have at least 3 elements, and in the left of the max value letter there should have at least one element, the same as in the right.

    3. The value of the letter is the ASCII value.

    Given a letter sequence, Coco wants to know how many Mountain Subsequences exist.

    Input

    Input contains multiple test cases.

    For each case there is a number n (1<= n <= 100000) which means the length of the letter sequence in the first line, and the next line contains the letter sequence.

    Please note that the letter sequence only contain lowercase letters.

    Output

    For each case please output the number of the mountain subsequences module 2012.

    Sample Input

    4
    abca
    

    Sample Output

    4

    HINT

    The 4 mountain subsequences are:

    aba, aca, bca, abca

    题意:

    给你一个长度为n的字符串仅由小写英文字母组成,求满足

    a1 < ...< ai < ai+1 < Amax > aj > aj+1 > ... > an  

    的子串的个数,其实也就是统计所有满足以某一元素为中心左边递增,右边递减的子串的数目,要求该子串

    最小长度为3,中心元素左右都至少有一个元素。

    思路:

    对于每一个字符,求出其左侧递增的序列个数,以及右侧递减的序列个数,然后相乘即可。

    举个例子来说:

    abca  对于a来说左侧没有递增的序列,所以为0,右侧不用计算了。然后对b来说左侧递增序列只有1个,右侧递减序列也只有1个,那么以b为中心的满足条件的个数为1个。

    接下来对于c来说,左侧递增序列为3个,右侧递减序列为1个,那么以c为中心的有3个。最后的a右侧没有递减的,所以为0;所以此样例结果为1+3=4;

    求每个字符的左侧递增和右侧递减实际上是一个相反的过程,只需要求出一个即可,具体实现过程看代码,代码中num数组是用来记录字母出现的个数,low和high数组分别记录左侧递增和右侧递减的序列的个数。

    代码:

    #include <bits/stdc++.h>
    #include <cstdlib>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <iostream>
    #include <algorithm>
    #include <string>
    #include <queue>
    #include <stack>
    #include <map>
    #include <set>
    
    #define IO ios::sync_with_stdio(false);
        cin.tie(0);
        cout.tie(0);
    typedef long long LL;
    const long long inf = 0x3f3f3f3f;
    const long long mod = 2012;
    const double PI = acos(-1.0);
    const double wyth=(sqrt(5)+1)/2.0;
    const int maxn = 100000+1000;
    const char week[7][10]= {"Monday","Tuesday","Wednesday","Thursday","Friday","Saturday","Sunday"};
    const char month[12][10]= {"Janurary","February","March","April","May","June","July",
                               "August","September","October","November","December"
                              };
    const int daym[2][13] = {{0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31},
        {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}
    };
    const int dir4[4][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}};
    const int dir8[8][2] = {{1, 0}, {0, 1}, {-1, 0}, {0, -1}, {1, 1}, {-1, -1}, {1, -1}, {-1, 1}};
    using namespace std;
    int num[maxn];
    int low[maxn];
    int high[maxn];
    int a[maxn];
    int main()
    {
        int n;
        while(cin>>n)
        {
            memset(num,0,sizeof(num));
            memset(low,0,sizeof(low));
            memset(high,0,sizeof(high));
            char s;
            for(int i=0; i<n; i++)
            {
                cin>>s;
                a[i]=s-'a';
            }
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<a[i]; j++)
                    low[i]=(low[i]+num[j])%mod;
                num[a[i]]=(num[a[i]]+low[i]+1)%mod;
            }
            memset(num,0,sizeof(num));
            for(int i=n-1; i>=0; i--)
            {
                for(int j=0; j<a[i]; j++)
                    high[i]=(high[i]+num[j])%mod;
                num[a[i]]=(num[a[i]]+high[i]+1)%mod;
            }
            LL ans=0;
            for(int i=0; i<n; i++)
                ans=(ans+high[i]*low[i])%mod;
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    使用npm安装一些包失败了的看过来(npm国内镜像介绍)(解决生成空的abp模板项目一直卡在还原cpm包中)
    .NET CORE 发布到IIS问题 HTTP ERROR 500.30
    .NET Core默认不支持GB2312,使用Encoding.GetEncoding(“GB2312”)的时候会抛出异常。
    .net c# 文件分片/断点续传之下载--客户端
    aspnetcore 实现断点续传
    C# 反射获取属性值、名称、类型以及集合的属性值、类型名称
    C# 3Des两种加密方式 (对应java中的desede/CBC/PKCS5Padding加密)
    Asp.NetCore3.1中多次读取Request.Body
    ASP.NET Core 2.0系列学习笔记-DI依赖注入
    C# Newtonsoft.Json JObject合并对象整理
  • 原文地址:https://www.cnblogs.com/aiguona/p/8663112.html
Copyright © 2020-2023  润新知