• hdu1151有向图的最小顶点覆盖


    有向图的最小路径覆盖=V-二分图最大匹配。

    Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles. 

    With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

    InputYour program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

    no_of_intersections 
    no_of_streets 
    S1 E1 
    S2 E2 
    ...... 
    Sno_of_streets Eno_of_streets 

    The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

    There are no blank lines between consecutive sets of data. Input data are correct. 
    OutputThe result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 
    Sample Input

    2
    4
    3
    3 4
    1 3
    2 3
    3
    3
    1 3
    1 2
    2 3

    Sample Output

    2
    1
    题意:给你一个DAG(有向无环图),要求最小顶点覆盖
    题解:根据公式DAG最小顶点覆盖=V-二分图最大匹配
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=120+5,maxn=100+5,inf=0x3f3f3f3f;
    
    int n,color[N];
    bool ok[N][N],used[N];
    
    bool match(int x)
    {
        for(int i=1;i<=n;i++)
        {
            if(ok[x][i]&&!used[i])
            {
                used[i]=1;
                if(color[i]==-1||match(color[i]))
                {
                    color[i]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int solve()
    {
        int ans=0;
        memset(color,-1,sizeof color);
        for(int i=1;i<=n;i++)
        {
            memset(used,0,sizeof used);
            ans+=match(i);
        }
        return ans;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        int t,m;
        cin>>t;
        while(t--){
            memset(ok,0,sizeof ok);
            cin>>n>>m;
            while(m--){
                int a,b;
                cin>>a>>b;
                ok[a][b]=1;
            }
            cout<<n-solve()<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    [LeetCode] Kth Smallest Element in a BST
    Dojo入门篇
    不要小看了get 与set
    怎样安装Windows7操作系统
    MFC Wizard创建的空应用程序中各个文件内容的解析
    hadoop hdfs空间满后重新启动不了
    树形结构——基本原理
    R语言pdf输出中文乱码处理
    Javascript基本概念梳理
    Java动态代理
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6748881.html
Copyright © 2020-2023  润新知