• ZOJ


    题目
    For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

    Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

    Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

    Input
    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

    Output
    For each case, print the answer in one line.

    Sample Input
    2
    3
    1 2 3
    5
    1 2 3 4 5
    Sample Output
    1
    6

    #include <cstdio>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int maxn=1e5+5;
    int a[maxn], bit[50];
    
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            memset(bit,0,sizeof(bit));
            int n,ans=0;
            cin>>n;
            for(int i=0;i<n;i++)
            {
                cin>>a[i];
                int l=31;
                while(l>=0)      //找出每个数二进制最大位的1,统计最大位1在l位的数的个数
                {
                    if(a[i] & 1 << l)
                        {
                            bit[l]++;
                            break;
                        }
                    l--;
                }
            }
            for(int i=0;i<n;i++)
            {
                int l=31;
                while(l>=0)           //从该数最大位1开始找起
                {
                    if(a[i]&1<<l)
                        break;
                    l--;
                }
                while(l>=0)        //一旦找到该数的某位上为0,即所有最大位1在该位上的数都可以和他组队
                {
                    if(!(a[i]&1<<l))
                        ans+=bit[l];
                    l--;
                }
            }
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    VMdomainXml
    C 本地文件夸网文件Cp操作
    C++ auto 与 register、static keyword 浅析
    机器学习笔记——SVM
    NYOJ 298-点的变换(经典矩阵解决点平移、缩放、翻转和旋转)
    HDU 5407 CRB and Candies(LCM +最大素因子求逆元)
    Java总结之网络
    五月份小结
    算法——字符串匹配之BM算法
    javaweb_page指令
  • 原文地址:https://www.cnblogs.com/acagain/p/9180738.html
Copyright © 2020-2023  润新知