• A+B


    题目描述:
    给定两个整数A和B,其表示形式是:从个位开始,每三位数用逗号","隔开。
    现在请计算A+B的结果,并以正常形式输出。
    输入:
    输入包含多组数据数据,每组数据占一行,由两个整数A和B组成(-10^9 < A,B < 10^9)。
    输出:
    请计算A+B的结果,并以正常形式输出,每组数据占一行。
    样例输入:
    -234,567,890 123,456,789
    1,234 2,345,678
    样例输出:
    -111111101
    2346912
    #include <iostream>
    #include<string>
    #include <cstring>
    #include<cstdlib>
    using namespace std;
    int main()
    {
    string a="",b="";
    string factor1,factor2;
    char ca[20],cb[20];
    int flag1,flag2,result,i;
    string::iterator it;
    while(cin>>a)
    {
    cin>>b;
    i=0;
    flag1=0;
    flag2=0;
    factor1="";
    factor2="";
    strcpy(ca,a.c_str());
    strcpy(cb,b.c_str());
    for(it=a.begin(); it<a.end(); it++)
    {
    if(ca[i]==',')
    flag1=1;
    if(flag1==0)
    {
    factor1+=ca[i];
    }
    flag1=0;
    i++;
    }
    i=0;
    for(it=b.begin(); it<b.end(); it++)
    {

    if(cb[i]==',')
    flag2=1;
    if(flag2==0)
    {
    factor2+=cb[i];
    }
    flag2=0;
    i++;
    }
    result=(atoi(factor1.c_str())+atoi(factor2.c_str()));
    cout<<result<<endl;
    }

    }


  • 相关阅读:
    python基础(5)
    python基础(4)
    python基础(3)
    python基础(2)
    第一个python程序(2)
    第一个python教程(1)
    【jQuery】
    【JavaScript】
    【练习】HTML+CSS
    【练习】Html
  • 原文地址:https://www.cnblogs.com/aboutblank/p/2360278.html
Copyright © 2020-2023  润新知