• (set)MG loves gold hdu6019


    MG loves gold
    Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
    Total Submission(s): 1607    Accepted Submission(s): 659
     
     
    Problem Description
    MG is a lucky boy. He is always be able to find gold from underground.
     
    It is known that the gold is a sequence with n elements, which has its own color C.
     
    MG can dig out a continuous area of sequence every time by using one shovel, but he's unwilling to dig the golds of the same color with one shovel.
     
    As a greedy person, he wish to take all the n golds away with least shovel.
    The rules also require MG not to dig twice at the same position.
     
    MG thought it very easy and he had himself disdained to take the job. As a bystander, could you please help settle the problem and calculate the answer?
     
    Input
    The first line is an integer T which indicates the case number.(1<=T<=10)
     
    And as for each case, there are 1 integer n in the first line which indicate gold-number(1<=n<=100000).
     
    Then there are n integers C in the next line, the x-th integer means the x-th gold’s color(|C|<=2000000000).
     
    Output
    As for each case, you need to output a single line.
     
    there should be one integer in the line which represents the least possible number of shovels after taking away all n golds.
     
    Sample Input
    2
    5
    1 1 2 3 -1
    5
    1 1 2 2 3
     
    Sample Output
    2
    3
     
    #include <iostream> //就是碰上相同的金坷垃就换铁锹。
    #include <cstdio>
    #include <set>
    using namespace std;
    int main()
    {
    int T;
    long long a;
    set<int> s;
    scanf("%d",&T);
    while(T--)
    {
    int n,sum=1;
    scanf("%d",&n);
    s.clear();
    for(int i=0;i<n;i++)
    {
    scanf("%d",&a); //少点用数组,可能会超时。
    if(s.count(a))
    {
    sum++;
    s.clear();
    }
    s.insert(a);
    }
    cout<<sum<<endl;
    }
    return 0;
    }
     
     
  • 相关阅读:
    NSPrediccate 查询
    集合 不可变集合
    集合 不可变
    考核题 7
    考核题 6
    考核题 4
    练习题12
    练习题3
    iOS 实现在string任意位置添加新的表情
    在 ZBarSDK 中使用Block回调传值 Block在扫描成功后 变为空
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9174853.html
Copyright © 2020-2023  润新知