• (并查集) HDU 1232 畅通工程


    Problem Description
    某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
     
    Input
    测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
    注意:两个城市之间可以有多条道路相通,也就是说
    3 3
    1 2
    1 2
    2 1
    这种输入也是合法的
    当N为0时,输入结束,该用例不被处理。 
     
    Output
    对每个测试用例,在1行里输出最少还需要建设的道路数目。 
     
    Sample Input
    4 2
    1 3
    4 3
    3 3
    1 2
    1 3
    2 3
    5 2
    1 2
    3 5
    999 0
    0
     
    Sample Output
    1
    0
    2
    998
     
    Hint
    Huge input, scanf is recommended. 
     
     
    根据题意,这个题可以用并查集,就是把已经联通的路并到一个集合,然后统计有多少个集合,最后得到的结果是集合的个数减去1。
    C++代码:
    #include<iostream>
    #include<cstdio>
    using namespace std;
    const int maxn = 1010;
    int father[maxn];
    //查找根。
    int Find(int x){
        while(x != father[x]){
            father[x] = father[father[x]];  //路径压缩。
            x = father[x];
        }
        return x;
    }
    //合并操作
    void Union(int a,int b){
        int ax = Find(a);
        int bx = Find(b);
        if(ax != bx){
            father[ax] = bx;
        }
    }
    int main(){
        int N,M;
        while(~scanf("%d",&N)){
            if(N == 0) break;
            cin>>M;
                    //初始化。
            for(int i = 1; i <= N; i++){
                father[i] = i;
            }
            int a,b;
            for(int i = 1; i <= M; i++){
                cin>>a>>b;
                Union(a,b);
            }
            int res = 0;
            for(int i = 1; i <= N; i++){
                if(father[i] == i)
                    res++;
            }
            cout<<res-1<<endl;
        }
        return 0;
    }    
  • 相关阅读:
    pecl install swoole 安装php扩展swoole
    RBAC
    mysql数据类型
    ES6——Proxy的this问题
    ES6——Proxy实现链式操作
    ES6——Symbol内置值
    ES6——yield例子
    ES6——Generator的next()方法
    ES6——Thunkify用法
    Linux学习day1
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/10898839.html
Copyright © 2020-2023  润新知