• L2-021. 点赞狂魔


    微博上有个“点赞”功能,你可以为你喜欢的博文点个赞表示支持。每篇博文都有一些刻画其特性的标签,而你点赞的博文的类型,也间接刻画了你的特性。然而有这么一种人,他们会通过给自己看到的一切内容点赞来狂刷存在感,这种人就被称为“点赞狂魔”。他们点赞的标签非常分散,无法体现出明显的特性。本题就要求你写个程序,通过统计每个人点赞的不同标签的数量,找出前3名点赞狂魔。

    输入格式:

    输入在第一行给出一个正整数N(<=100),是待统计的用户数。随后N行,每行列出一位用户的点赞标签。格式为“Name K F1 ... FK”,其中 Name 是不超过8个英文小写字母的非空用户名,1<=K<=1000,Fi(i=1, ..., K)是特性标签的编号,我们将所有特性标签从1到107编号。数字间以空格分隔。

    输出格式:

    统计每个人点赞的不同标签的数量,找出数量最大的前3名,在一行中顺序输出他们的用户名,其间以1个空格分隔,且行末不得有多余空格。如果有并列,则输出标签出现次数平均值最小的那个,题目保证这样的用户没有并列。若不足3人,则用“-”补齐缺失,例如“mike jenny -”就表示只有2人。

    输入样例:

    5
    bob 11 101 102 103 104 105 106 107 108 108 107 107
    peter 8 1 2 3 4 3 2 5 1
    chris 12 1 2 3 4 5 6 7 8 9 1 2 3
    john 10 8 7 6 5 4 3 2 1 7 5
    jack 9 6 7 8 9 10 11 12 13 14
    

    输出样例:

    jack chris john
    
    #include<iostream>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<queue>
    #include<set>
    #include<functional>
    using namespace std;
    
    const int N = 100 + 5;
    
    struct node{
        string ID = "-";
        int cnt = 0;
        double avg = 0.0;
        bool operator < (const node &x)const {
            if(cnt == x.cnt) return avg < x.avg;
            return cnt > x.cnt;
        }
    }Node[N];
    set<int> S;
    int main(){
        int n, u, k;
        cin >> n;
        for(int i = 0; i < n; i++){
            cin >> Node[i].ID;
            cin >> k;
            S.clear();
            double sum = 0.0;
            for(int j = 0; j < k; j++){
                cin >> u;
                sum += u;
                S.insert(u);
            }
    
            Node[i].cnt = S.size();
            Node[i].avg = k * 1.0 / Node[i].cnt;
        }
    
        sort(Node, Node + n);
    
        cout << Node[0].ID << " " << Node[1].ID << " " << Node[2].ID << endl;
    }
  • 相关阅读:
    Android的数据存储
    Servlet第一天
    JavaScript高级程序设计读书笔记(3)
    Interesting Papers on Face Recognition
    Researchers Study Ear Biometrics
    IIS 发生意外错误 0x8ffe2740
    Father of fractal geometry, Benoit Mandelbrot has passed away
    Computer vision scientist David Mumford wins National Medal of Science
    Pattern Recognition Review Papers
    盒模型bug的解决方法
  • 原文地址:https://www.cnblogs.com/Pretty9/p/8635448.html
Copyright © 2020-2023  润新知