• Problem G: If We Were a Child Again


    Problem G: If We Were a Child Again
    Time Limit: 1 Sec Memory Limit: 128 MB
    Submit: 18 Solved: 14
    [Submit][Status][Web Board]
    Description
    The Problem

    The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

    But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

    Input
    Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

    Output
    A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

    Sample Input
    110 / 100
    99 % 10
    2147483647 / 2147483647
    2147483646 % 2147483647
    Sample Output
    1
    9
    1
    2147483646

    my answer:

    #include<iostream>
    #include<cstring>
    #include<string>
    using namespace std;
    int main()
    {
        char a[100];
        int t[101];
        int sum,b,i;
        char c;
        while(cin>>a)
        {
            cin>>c;
            cin>>b;
            int t1=strlen(a);
            sum=a[0]-'0';
     
            for( i=0;i!=t1;i++){
                t[i]=sum/b;
                sum=sum%b;
                if(sum<b&&i<t1-1){
                sum=(sum*10+a[i+1]-'0');
     
                }
            }
            if(c=='%')
                cout<<sum<<endl;
            else{
            int start=0;
            while(!t[start])start++;
            if(start==i)cout<<1<<endl;
            else {
            for(int j=start;j<i;j++)
                cout<<t[j];
            cout<<endl;
            }
            }
        }
        return 0;
    }
  • 相关阅读:
    css三角形拼接多边形
    弹框提示Request failed with status code 401
    el-upload组件上传闪动
    vue-element-admin校验不通过 页面跳到滚动位置
    请求方式错误
    IE兼容11支持10不支持
    二次封装elementui弹框
    element多张上传的去除动画
    奇怪的知识增加了,python切片特点以及下标的活用,可变tuple
    LeafHttp,同步、异步请求的Http库
  • 原文地址:https://www.cnblogs.com/NYNU-ACM/p/4236900.html
Copyright © 2020-2023  润新知